summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyenpi2022-01-15 14:16:30 +0000
committerEyenpi2022-01-15 14:16:30 +0000
commit92b296d0c3d5336187baeae8ea107ba132a6f639 (patch)
treea931d5f872b866f595c153687e6ae473b0d782c9
downloadaur-92b296d0c3d5336187baeae8ea107ba132a6f639.tar.gz
gtk themes added
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dadf42ae385e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cutefish-gtk-themes-git
+ pkgdesc = Cutefish gtk dark/light themes
+ pkgver = 0.7.r0.g91f762f
+ pkgrel = 1
+ url = https://github.com/cutefishos/gtk-themes
+ arch = any
+ groups = cutefish-git
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ provides = cutefish-gtk-themes
+ conflicts = cutefish-gtk-themes
+ source = git+https://github.com/cutefishos/gtk-themes.git
+ sha512sums = SKIP
+
+pkgname = cutefish-gtk-themes-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c883151a22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ali Nabipour <alinabipour01@gmail.com>
+
+pkgname=cutefish-gtk-themes-git
+_pkgname=cutefish-gtk-themes
+pkgver=0.7.r0.g91f762f
+pkgrel=1
+pkgdesc="Cutefish gtk dark/light themes"
+arch=('any')
+url="https://github.com/cutefishos/gtk-themes"
+license=('GPL')
+groups=('cutefish-git')
+depends=()
+makedepends=('extra-cmake-modules' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd gtk-themes
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd gtk-themes
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd gtk-themes
+ make DESTDIR="$pkgdir" install
+}