summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyenpi2021-08-17 12:11:28 +0430
committerEyenpi2021-08-17 12:11:28 +0430
commitcf04a769893dfa3f711e3cda2baa5a5837d27c89 (patch)
tree76c7699cc300ad849a3ca16eae8ace5a865216ae
downloadaur-cf04a769893dfa3f711e3cda2baa5a5837d27c89.tar.gz
initial release
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14b0f2238305
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cutefish-launcher-git
+ pkgdesc = CutefishOS's full-screen application launcher
+ pkgver = 0.3.r11.gb6fa3ac
+ pkgrel = 1
+ url = https://github.com/cutefishos/launcher
+ arch = x86_64
+ groups = cutefish-git
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = ninja
+ makedepends = qt5-tools
+ makedepends = git
+ depends = fishui-git
+ depends = kwindowsystem
+ depends = libcutefish-git
+ provides = cutefish-launcher
+ conflicts = cutefish-launcher
+ conflicts = deepin-kwin
+ source = git+https://github.com/cutefishos/launcher.git
+ sha512sums = SKIP
+
+pkgname = cutefish-launcher-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02b901daecb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ali Nabipour <alinabipour01@gmail.com>
+
+pkgname=cutefish-launcher-git
+_pkgname=cutefish-launcher
+pkgver=0.3.r11.gb6fa3ac
+pkgrel=1
+pkgdesc="CutefishOS's full-screen application launcher"
+arch=('x86_64')
+url="https://github.com/cutefishos/launcher"
+license=('GPL')
+groups=('cutefish-git')
+depends=('fishui-git' 'kwindowsystem' 'libcutefish-git')
+makedepends=('extra-cmake-modules' 'ninja' 'qt5-tools' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname" "deepin-kwin")
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd launcher
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd launcher
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd launcher
+ make DESTDIR="$pkgdir" install
+}