summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyenpi2021-08-17 12:14:18 +0430
committerEyenpi2021-08-17 12:14:18 +0430
commit9a9dad7243a8bdf1d40bf6cbcc276a90fe5c6a5b (patch)
tree0be5a7b1ac228de02998e2034e48e1d6a472bbe5
downloadaur-9a9dad7243a8bdf1d40bf6cbcc276a90fe5c6a5b.tar.gz
initial release
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffff494e2544
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cutefish-wallpapers-git
+ pkgdesc = CutefishOS's system wallpaper
+ pkgver = 0.2.r5.g36befd9
+ pkgrel = 1
+ url = https://github.com/cutefishos/wallpapers
+ arch = any
+ groups = cutefish-git
+ license = GPL
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = git
+ provides = cutefish-wallpapers
+ conflicts = cutefish-wallpapers
+ source = git+https://github.com/cutefishos/wallpapers.git
+ sha512sums = SKIP
+
+pkgname = cutefish-wallpapers-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9382e2a977a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ali Nabipour <alinabipour01@gmail.com>
+
+pkgname=cutefish-wallpapers-git
+_pkgname=cutefish-wallpapers
+pkgver=0.2.r5.g36befd9
+pkgrel=1
+pkgdesc="CutefishOS's system wallpaper"
+arch=('any')
+url="https://github.com/cutefishos/wallpapers"
+license=('GPL')
+groups=('cutefish-git')
+depends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+makedepends=('cmake' 'ninja' 'git')
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd wallpapers
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd wallpapers
+
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr .
+ ninja
+}
+
+package() {
+ cd wallpapers
+ DESTDIR="$pkgdir" ninja install
+}