summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2017-12-21 00:12:04 +0900
committerJiachen Yang2017-12-21 00:12:04 +0900
commite26b8bace89d4435c926dd28d8d70f3deae7ccb3 (patch)
treee20901b7963b2b52afae04602103b1d79bb5c89f
parent84cd0f8265c1ed97456caa245972287fdc2a6a09 (diff)
downloadaur-e26b8bace89d4435c926dd28d8d70f3deae7ccb3.tar.gz
moving cutegram from community to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62592e86bd02..9ebe41480455 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cutegram
pkgdesc = A different telegram client from Aseman team
- pkgver = 2.7.0
- pkgrel = 3
+ pkgver = 2.7.1
+ pkgrel = 4
url = http://aseman.co/en/products/cutegram/
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
depends = qt5-imageformats
- depends = qt5-webkit>=5.5
- depends = telegramqml>=0.9
- depends = libqtelegram-ae>=2:6.0
+ depends = qt5-webkit
+ depends = telegramqml>=0.9.1
+ depends = libqtelegram-ae>=3:6.1
optdepends = gst-plugins-bad: audio support
optdepends = gst-plugins-good: audio and notification sound
provides = cutegram
@@ -18,8 +19,10 @@ pkgbase = cutegram
conflicts = sigram
conflicts = cutegram
replaces = cutegram-cn
- source = https://github.com/Aseman-Land/Cutegram/archive/v2.7.0-stable.tar.gz
- sha256sums = 5ff195269f2492c625cca4b8eca6134c938e2b5a759019074e486335046c02d9
+ source = Cutegram-2.7.1.tar.gz::https://github.com/Aseman-Land/Cutegram/archive/v2.7.1-stable.tar.gz
+ source = asemantools::git+https://github.com/Aseman-Land/aseman-qt-tools.git#commit=91bf14b790c749bcaaddb09a8124ef6415a93906
+ sha256sums = f1cfc6bd3a1d33c2348f23ea43d923419b33576059791a071f2780db11059cf4
+ sha256sums = SKIP
pkgname = cutegram
diff --git a/PKGBUILD b/PKGBUILD
index 303f9e887619..cc01ab5986c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,31 +7,35 @@
pkgname=cutegram
_pkgname=Cutegram
-pkgver=2.7.0
-pkgrel=3
+pkgver=2.7.1
+pkgrel=4
pkgdesc="A different telegram client from Aseman team"
arch=('i686' 'x86_64')
url="http://aseman.co/en/products/cutegram/"
license=('GPL')
-depends=('qt5-imageformats' 'qt5-webkit>=5.5' 'telegramqml>=0.9' 'libqtelegram-ae>=2:6.0')
+depends=('qt5-imageformats' 'qt5-webkit' 'telegramqml>=0.9.1' 'libqtelegram-ae>=3:6.1')
optdepends=('gst-plugins-bad: audio support'
'gst-plugins-good: audio and notification sound')
+makedepends=('git')
conflicts=('cutegram-git' 'sigram-git' 'sigram' 'cutegram')
provides=('cutegram')
replaces=('cutegram-cn')
-source=("https://github.com/Aseman-Land/Cutegram/archive/v$pkgver-stable.tar.gz")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Aseman-Land/Cutegram/archive/v${pkgver}-stable.tar.gz"
+ "asemantools"::"git+https://github.com/Aseman-Land/aseman-qt-tools.git#commit=91bf14b790c749bcaaddb09a8124ef6415a93906")
-sha256sums=('5ff195269f2492c625cca4b8eca6134c938e2b5a759019074e486335046c02d9')
+sha256sums=('f1cfc6bd3a1d33c2348f23ea43d923419b33576059791a071f2780db11059cf4'
+ 'SKIP')
prepare() {
cd "${srcdir}/${_pkgname}-$pkgver-stable"
+ git clone $srcdir/asemantools Cutegram/asemantools
mkdir -p build
}
build() {
cd "${srcdir}/${_pkgname}-$pkgver-stable/build"
- qmake-qt5 -r .. PREFIX=/usr
+ qmake-qt5 -r .. PREFIX=/usr QMAKE_CFLAGS_ISYSTEM=
make
}