summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2016-07-05 21:23:59 +0900
committerJiachen Yang2016-07-05 21:23:59 +0900
commit5acd68a55b42298a7a49f304fb3fff6d2a04a23b (patch)
tree6158f463298f4da2532a5ac10afccf25824e9bd4
parente907076f956f8217af7b6a95f5ac8921cc7940d8 (diff)
downloadaur-5acd68a55b42298a7a49f304fb3fff6d2a04a23b.tar.gz
cutegram-git update to 2.9.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c9d7b17ecaa..2db280fb9937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
pkgbase = cutegram-git
pkgdesc = Telegram client by Aseman Land
- pkgver = 2.7.1.stable.r8.g5645a99
+ pkgver = 2.9.5.dev.r10.g2827175
pkgrel = 1
url = http://aseman.co/cutegram
arch = i686
arch = x86_64
license = GPL
makedepends = git
- depends = qt5-base
- depends = qt5-declarative
- depends = qt5-multimedia
- depends = qt5-quick1
- depends = qt5-webkit
- depends = qt5-imageformats
- depends = qt5-graphicaleffects
- depends = qt5-quickcontrols
- depends = telegramqml>=0.9
+ depends = libqtelegram-ae
+ depends = telegramqml
+ depends = aseman-qt-tools
optdepends = gst-plugins-good: for audio and notification support
optdepends = gst-plugins-bad: for audio support
source = cutegram-git::git+https://github.com/Aseman-Land/Cutegram.git
- source = asemantools::git+https://github.com/Aseman-Land/aseman-qt-tools.git
- md5sums = SKIP
md5sums = SKIP
pkgname = cutegram-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e4e165f65e2..811a38dca624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,18 @@
# Contributor in Chakra: totoloco <totoloco@gmx.com>
pkgname=cutegram-git
-pkgver=2.7.1.stable.r8.g5645a99
+pkgver=2.9.5.dev.r10.g2827175
pkgrel=1
pkgdesc="Telegram client by Aseman Land"
arch=('i686' 'x86_64')
url="http://aseman.co/cutegram"
license=('GPL')
-depends=('qt5-base' 'qt5-declarative' 'qt5-multimedia' 'qt5-quick1'
- 'qt5-webkit' 'qt5-imageformats' 'qt5-graphicaleffects'
- 'qt5-quickcontrols' 'telegramqml>=0.9')
+depends=('libqtelegram-ae' 'telegramqml' 'aseman-qt-tools')
optdepends=('gst-plugins-good: for audio and notification support'
'gst-plugins-bad: for audio support')
makedepends=('git')
-source=("${pkgname}"::"git+https://github.com/Aseman-Land/Cutegram.git"
- "asemantools"::"git+https://github.com/Aseman-Land/aseman-qt-tools.git")
-md5sums=('SKIP' 'SKIP')
+source=("${pkgname}"::"git+https://github.com/Aseman-Land/Cutegram.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -32,15 +29,12 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- git submodule init
- git config submodule.asemantools.url $srcdir/asemantools
- git submodule update
- mkdir -p build
+ mkdir -p build
}
build() {
cd "${srcdir}/${pkgname}/build"
- qmake-qt5 -r .. QMAKE_CFLAGS_ISYSTEM= PREFIX=/usr
+ qmake-qt5 .. QMAKE_CFLAGS_ISYSTEM= PREFIX=/usr
make
}