summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Majewsky2015-07-18 01:12:45 +0200
committerStefan Majewsky2015-07-18 01:12:52 +0200
commitef160b4ef368170ac8026f86d2386f9d60d7737a (patch)
tree0888c07169bfba9b3de726c633aba0b06aa30d52
downloadaur-ef160b4ef368170ac8026f86d2386f9d60d7737a.tar.gz
import from old AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a858a4f711e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cutelyst
+ pkgdesc = A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://cutelyst.org
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ depends = qt5-base
+ depends = uwsgi
+ depends = grantlee-qt5
+ source = cutelyst::git+https://gitorious.org/cutelyst/cutelyst.git#tag=r0.5.0
+ md5sums = SKIP
+
+pkgname = cutelyst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76891ca51740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Stefan Majewsky <majewsky@gmx.net>
+pkgname=cutelyst
+pkgver=0.5.0
+pkgrel=1
+epoch=
+pkgdesc="A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework."
+arch=('i686' 'x86_64')
+url="http://cutelyst.org"
+license=('LGPL2.1')
+groups=()
+depends=('qt5-base' 'uwsgi' 'grantlee-qt5')
+# FIXME: no 'clearsilver' in depends=() because the clearsilver dependency is
+# not picked up by cutelyst's build (looks like a problem with cutelyst's CMake
+# scripts: it looks for libneo_cs.a which is not included in
+# clearsilver.pkg.xz)
+makedepends=('cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("cutelyst::git+https://gitorious.org/cutelyst/cutelyst.git#tag=r${pkgver}")
+noextract=()
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+pkgver() {
+ # The $pkgver is the correct version because we checked out exactly that tag.
+ echo $pkgver
+}
+
+build() {
+ mkdir -p "$srcdir/$pkgname/build"
+ cd "$srcdir/$pkgname/build"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ".."
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}