summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Moustafine2016-11-15 19:55:16 +0300
committerMarat Moustafine2016-11-15 19:55:16 +0300
commit7f784c0f889dff96064698cb2c699ef431b8cbd4 (patch)
tree0f5b4c47fd49e42f45a6419a9575c9c531ea8ebc
downloadaur-7f784c0f889dff96064698cb2c699ef431b8cbd4.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06340a68d42a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cutelyst-git
+ pkgdesc = A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework
+ pkgver = 1.0.0+2+g2f101cb
+ pkgrel = 1
+ url = https://github.com/cutelyst/cutelyst
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ makedepends = git
+ makedepends = uwsgi
+ depends = grantlee
+ depends = libsimplemail-qt
+ optdepends = uwsgi: for the uWSGI engine
+ provides = cutelyst
+ conflicts = cutelyst
+ source = git+https://github.com/cutelyst/cutelyst.git
+ sha256sums = SKIP
+
+pkgname = cutelyst-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc578be98397
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Marat Moustafine <m-dash-moustafine-at-yandex-dot-ru>
+
+_pkgname=cutelyst
+pkgname=$_pkgname-git
+pkgver=1.0.0+2+g2f101cb
+pkgrel=1
+pkgdesc='A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework'
+arch=('i686' 'x86_64')
+url=https://github.com/$_pkgname/$_pkgname
+license=('LGPL2.1')
+depends=('grantlee' 'libsimplemail-qt')
+makedepends=('cmake' 'git' 'uwsgi')
+optdepends=('uwsgi: for the uWSGI engine')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed -r 's/^r//;s/-/+/g'
+}
+
+build () {
+ cd $_pkgname
+ mkdir -p build
+
+ cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUWSGI_PLUGINS_DIR=/usr/lib/uwsgi \
+ ..
+ make
+}
+
+package() {
+ cd $_pkgname/build
+ make DESTDIR=$pkgdir install
+}