summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Moustafine2019-03-10 21:35:09 +0300
committerMarat Moustafine2019-03-10 21:35:09 +0300
commitdbe3a2aab426d71db31d17ca5103ce1f4761d53c (patch)
tree2ce3e39cd6eba1e996552f1475d3480ee76c040b
parentf61572a38853b5bbf15755a8ea88684c1f5725d7 (diff)
downloadaur-dbe3a2aab426d71db31d17ca5103ce1f4761d53c.tar.gz
Update the build
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e293948ebf3..7370d878c1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='A Web Framework built on top of Qt, using the simple approach of Cataly
arch=('i686' 'x86_64')
url=https://github.com/$_pkgname/$_pkgname
license=('LGPL2.1')
-depends=('grantlee' 'libsimplemail-qt')
+depends=('grantlee' 'jemalloc' 'libmemcached' 'libpwquality' 'libsimplemail-qt')
makedepends=('cmake' 'git' 'uwsgi')
optdepends=('uwsgi: for the uWSGI engine')
provides=($_pkgname)
@@ -29,7 +29,10 @@ build () {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DUWSGI_PLUGINS_DIR=/usr/lib/uwsgi \
+ -DBUILD_ALL=ON \
+ -DPLUGIN_VIEW_CLEARSILVER=OFF \
+ -DBUILD_TESTS=OFF \
+ -DBUILD_EXAMPLES=OFF \
..
make
}