summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-07-22 16:11:55 +0000
committerBalló György2020-07-22 16:11:55 +0000
commit699eb02e36847fc7e4e339d68b0c37ab234dc157 (patch)
treeaebbdba040d7536a8559f657c4378a633d86b12e
parentb9e72d0b6deb6023ca5f0ea6d20e6db4c71259de (diff)
downloadaur-699eb02e36847fc7e4e339d68b0c37ab234dc157.tar.gz
Fix build, fix other things
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch11
-rw-r--r--cutemarked.appdata.xml31
4 files changed, 76 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4697308292ff..8d1e32f9d960 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue Dec 6 14:21:08 UTC 2016
pkgbase = cutemarked
- pkgdesc = Qt Markdown Editor
+ pkgdesc = Qt Markdown editor with live HTML preview, math expressions and code syntax highlighting
pkgver = 0.11.3
pkgrel = 1
url = https://github.com/cloose/CuteMarkEd
- arch = i686
arch = x86_64
- license = GPL2
+ license = GPL
makedepends = qt5-tools
- depends = qt5-webkit
+ depends = discount
+ depends = hicolor-icon-theme
depends = hunspell
- depends = discount>=2.1.7
- source = https://github.com/cloose/CuteMarkEd/archive/v0.11.3.tar.gz
+ depends = qt5-webkit
+ optdepends = mathjax2: formula support
+ source = https://github.com/cloose/CuteMarkEd/archive/v0.11.3/CuteMarkEd-0.11.3.tar.gz
+ source = cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
+ source = cutemarked.appdata.xml
sha256sums = 78a41808c2f0452375810abdff76eeaaee012f8d1368a2b8772ec6b4d2ceeec8
+ sha256sums = b9f6505f12c72b7f46b68c48452e3bc85d905c1640e5db04b341d4c57860d25c
+ sha256sums = 3bfe02706a664a03da411138301d39a613f8e9770120b69a43e5e96f3ec85fa0
pkgname = cutemarked
diff --git a/PKGBUILD b/PKGBUILD
index 3c94b05a362f..ee1e4d290d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,40 @@
-# Maintainer: Daniel Nagy <danielnagy at gmx de>
-# Maintainer: Sascha Pfau
+# Contributor: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Sascha Pfau
_realname=CuteMarkEd
pkgname=cutemarked
pkgver=0.11.3
pkgrel=1
-pkgdesc="Qt Markdown Editor"
+pkgdesc="Qt Markdown editor with live HTML preview, math expressions and code syntax highlighting"
url="https://github.com/cloose/CuteMarkEd"
-arch=('i686' 'x86_64')
-license=( "GPL2" )
-depends=( "qt5-webkit" "hunspell" "discount>=2.1.7" )
-makedepends=( 'qt5-tools' )
-source=( "https://github.com/cloose/CuteMarkEd/archive/v$pkgver.tar.gz" )
-sha256sums=('78a41808c2f0452375810abdff76eeaaee012f8d1368a2b8772ec6b4d2ceeec8')
+arch=(x86_64)
+license=(GPL)
+depends=(discount hicolor-icon-theme hunspell qt5-webkit)
+makedepends=(qt5-tools)
+optdepends=('mathjax2: formula support')
+source=(https://github.com/cloose/CuteMarkEd/archive/v$pkgver/$_realname-$pkgver.tar.gz
+ cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
+ cutemarked.appdata.xml)
+sha256sums=('78a41808c2f0452375810abdff76eeaaee012f8d1368a2b8772ec6b4d2ceeec8'
+ 'b9f6505f12c72b7f46b68c48452e3bc85d905c1640e5db04b341d4c57860d25c'
+ '3bfe02706a664a03da411138301d39a613f8e9770120b69a43e5e96f3ec85fa0')
prepare() {
- cd $srcdir/$_realname-$pkgver
- sed -i -e "s,#include <discount/mkdio.h>,#include <mkdio.h>,g" app-static/converter/discountmarkdownconverter.cpp
- # Fix: Add FencedCode option
- sed -i -e "s,unsigned long converterOptions = MKD_TOC | MKD_NOSTYLE;,unsigned long converterOptions = MKD_TOC | MKD_NOSTYLE | MKD_FENCEDCODE;,g" app-static/converter/discountmarkdownconverter.cpp
+ cd $_realname-$pkgver
+ patch -Np1 -i ../cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
+ sed -i 's|http[s]\?://cdn.mathjax.org/mathjax/latest/MathJax.js|file:///usr/share/mathjax2/MathJax.js|' \
+ app-static/template/htmltemplate.cpp app/template_presentation.html
+ sed -i '/syntax.html/a <file>syntax_hu_HU.html</file>' app/resources.qrc
+ sed -i 's/syntax_hu/syntax_hu_HU/' app/translations/cutemarked_hu_HU.ts
}
build() {
- cd $srcdir/$_realname-$pkgver
+ cd $_realname-$pkgver
qmake
- make || true # the first make run might fail
make
}
package() {
- cd $srcdir/$_realname-$pkgver
+ cd $_realname-$pkgver
make INSTALL_ROOT="$pkgdir" install
- mkdir -p "$pkgdir"/usr/bin
- #ln -s ../lib/qt/bin/cutemarked "$pkgdir"/usr/bin/cutemarked
+ install -Dm644 ../$pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$pkgname.appdata.xml"
}
diff --git a/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch b/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
new file mode 100644
index 000000000000..5e585945902c
--- /dev/null
+++ b/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
@@ -0,0 +1,11 @@
+diff -Nru a/app/optionsdialog.cpp b/app/optionsdialog.cpp
+--- a/app/optionsdialog.cpp 2016-03-28 13:48:50.000000000 +0200
++++ b/app/optionsdialog.cpp 2018-06-05 07:28:09.086517828 +0200
+@@ -17,6 +17,7 @@
+ #include "optionsdialog.h"
+ #include "ui_optionsdialog.h"
+
++#include <QAction>
+ #include <QFontComboBox>
+ #include <QItemEditorFactory>
+ #include <QKeySequence>
diff --git a/cutemarked.appdata.xml b/cutemarked.appdata.xml
new file mode 100644
index 000000000000..007580c63860
--- /dev/null
+++ b/cutemarked.appdata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>cutemarked.desktop</id>
+ <name>CuteMarkEd</name>
+ <project_license>CC0-1.0</project_license>
+ <metadata_license>GPL-2.0+</metadata_license>
+ <summary>Qt Markdown Editor</summary>
+ <developer_name>Christian Loose</developer_name>
+ <description>
+ <p>
+ A Qt-based, free and open source Markdown editor with live HTML preview, math expressions, code and markdown syntax highlighting.
+ </p>
+ <p>Features:</p>
+ <ul>
+ <li>Multiple styles</li>
+ <li>Live HTML Preview</li>
+ <li>HTML and PDF Export</li>
+ <li>Document statistics</li>
+ <li>Code Syntax Highlighting</li>
+ <li>Spell Checking</li>
+ ​</ul>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source">https://cloose.github.io/CuteMarkEd/images/screenshot_06.png</image>
+ </screenshot>
+ </screenshots>
+ <url type="homepage">https://cloose.github.io/CuteMarkEd/</url>
+ <url type="bugtracker">https://github.com/cloose/CuteMarkEd/issues</url>
+ <url type="help">https://github.com/cloose/CuteMarkEd/blob/develop/README.md</url>
+</component>