summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-09-05 19:29:24 +0200
committerhaawda2020-09-05 19:29:24 +0200
commitd375b4ee75707d6ecd34da8521ebdc1a223f53a2 (patch)
tree2c033559811bf6bfe18cd28fb48db7ac21d61136
parent699eb02e36847fc7e4e339d68b0c37ab234dc157 (diff)
downloadaur-d375b4ee75707d6ecd34da8521ebdc1a223f53a2.tar.gz
pull from NG-git-repo
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD60
-rw-r--r--cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch11
-rw-r--r--cutemarked.appdata.xml31
4 files changed, 48 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d1e32f9d960..667814727c60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = cutemarked
- pkgdesc = Qt Markdown editor with live HTML preview, math expressions and code syntax highlighting
- pkgver = 0.11.3
+ pkgdesc = Qt Markdown Editor
+ pkgver = 20200625.r910
pkgrel = 1
- url = https://github.com/cloose/CuteMarkEd
+ url = https://github.com/Waqar144/CuteMarkEd-NG
+ arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
+ makedepends = git
makedepends = qt5-tools
- depends = discount
- depends = hicolor-icon-theme
- depends = hunspell
- depends = qt5-webkit
- optdepends = mathjax2: formula support
- source = https://github.com/cloose/CuteMarkEd/archive/v0.11.3/CuteMarkEd-0.11.3.tar.gz
- source = cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
- source = cutemarked.appdata.xml
- sha256sums = 78a41808c2f0452375810abdff76eeaaee012f8d1368a2b8772ec6b4d2ceeec8
- sha256sums = b9f6505f12c72b7f46b68c48452e3bc85d905c1640e5db04b341d4c57860d25c
- sha256sums = 3bfe02706a664a03da411138301d39a613f8e9770120b69a43e5e96f3ec85fa0
+ depends = qt5-webengine
+ source = git+https://github.com/Waqar144/CuteMarkEd-NG.git#commit=28c6ea8
+ source = git+https://github.com/hunspell/hunspell.git
+ source = git+https://github.com/mity/md4c
+ source = https://github.com/pbek/qmarkdowntextedit
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = cutemarked
diff --git a/PKGBUILD b/PKGBUILD
index ee1e4d290d38..7b5bed48ec1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,46 @@
-# Contributor: Daniel Nagy <danielnagy at gmx de>
-# Contributor: Sascha Pfau
+# Contributor: Aetf <aetf at unlimitedcodeworks dot xyz>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-_realname=CuteMarkEd
+_gitname=CuteMarkEd-NG
pkgname=cutemarked
-pkgver=0.11.3
+pkgver=20200625.r910
pkgrel=1
-pkgdesc="Qt Markdown editor with live HTML preview, math expressions and code syntax highlighting"
-url="https://github.com/cloose/CuteMarkEd"
-arch=(x86_64)
-license=(GPL)
-depends=(discount hicolor-icon-theme hunspell qt5-webkit)
-makedepends=(qt5-tools)
-optdepends=('mathjax2: formula support')
-source=(https://github.com/cloose/CuteMarkEd/archive/v$pkgver/$_realname-$pkgver.tar.gz
- cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
- cutemarked.appdata.xml)
-sha256sums=('78a41808c2f0452375810abdff76eeaaee012f8d1368a2b8772ec6b4d2ceeec8'
- 'b9f6505f12c72b7f46b68c48452e3bc85d905c1640e5db04b341d4c57860d25c'
- '3bfe02706a664a03da411138301d39a613f8e9770120b69a43e5e96f3ec85fa0')
+pkgdesc="Qt Markdown Editor"
+url="https://github.com/Waqar144/${_gitname}"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('qt5-webengine')
+makedepends=('git' 'qt5-tools')
+source=("git+$url.git#commit=28c6ea8"
+ "git+https://github.com/hunspell/hunspell.git"
+ "git+https://github.com/mity/md4c"
+ "https://github.com/pbek/qmarkdowntextedit"
+ )
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "%s.r%s" $(git log -1 --format="%cd" --date=short | tr -d '-') $(git rev-list --count HEAD)
+}
prepare() {
- cd $_realname-$pkgver
- patch -Np1 -i ../cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
- sed -i 's|http[s]\?://cdn.mathjax.org/mathjax/latest/MathJax.js|file:///usr/share/mathjax2/MathJax.js|' \
- app-static/template/htmltemplate.cpp app/template_presentation.html
- sed -i '/syntax.html/a <file>syntax_hu_HU.html</file>' app/resources.qrc
- sed -i 's/syntax_hu/syntax_hu_HU/' app/translations/cutemarked_hu_HU.ts
+ cd $_gitname
+ git submodule init
+ for __submodule in hunspell md4c qmarkdowntextedit
+ do git config submodule.${__submodule}.url "$srcdir"/${_gitname}/3rdparty/${__submodule}
+ done
+ git submodule update
}
build() {
- cd $_realname-$pkgver
- qmake
+ cd $_gitname
+ [[ -d build ]] || mkdir build
+ cd build
+ qmake ..
make
}
+
package() {
- cd $_realname-$pkgver
+ cd $_gitname/build
make INSTALL_ROOT="$pkgdir" install
- install -Dm644 ../$pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$pkgname.appdata.xml"
}
diff --git a/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch b/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
deleted file mode 100644
index 5e585945902c..000000000000
--- a/cutemarked-0.11.3-fix-build-against-qt-5.11.0.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nru a/app/optionsdialog.cpp b/app/optionsdialog.cpp
---- a/app/optionsdialog.cpp 2016-03-28 13:48:50.000000000 +0200
-+++ b/app/optionsdialog.cpp 2018-06-05 07:28:09.086517828 +0200
-@@ -17,6 +17,7 @@
- #include "optionsdialog.h"
- #include "ui_optionsdialog.h"
-
-+#include <QAction>
- #include <QFontComboBox>
- #include <QItemEditorFactory>
- #include <QKeySequence>
diff --git a/cutemarked.appdata.xml b/cutemarked.appdata.xml
deleted file mode 100644
index 007580c63860..000000000000
--- a/cutemarked.appdata.xml
+++ /dev/null
@@ -1,31 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<component type="desktop-application">
- <id>cutemarked.desktop</id>
- <name>CuteMarkEd</name>
- <project_license>CC0-1.0</project_license>
- <metadata_license>GPL-2.0+</metadata_license>
- <summary>Qt Markdown Editor</summary>
- <developer_name>Christian Loose</developer_name>
- <description>
- <p>
- A Qt-based, free and open source Markdown editor with live HTML preview, math expressions, code and markdown syntax highlighting.
- </p>
- <p>Features:</p>
- <ul>
- <li>Multiple styles</li>
- <li>Live HTML Preview</li>
- <li>HTML and PDF Export</li>
- <li>Document statistics</li>
- <li>Code Syntax Highlighting</li>
- <li>Spell Checking</li>
- ​</ul>
- </description>
- <screenshots>
- <screenshot type="default">
- <image type="source">https://cloose.github.io/CuteMarkEd/images/screenshot_06.png</image>
- </screenshot>
- </screenshots>
- <url type="homepage">https://cloose.github.io/CuteMarkEd/</url>
- <url type="bugtracker">https://github.com/cloose/CuteMarkEd/issues</url>
- <url type="help">https://github.com/cloose/CuteMarkEd/blob/develop/README.md</url>
-</component>