summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2015-06-09 05:22:55 -0400
committerGraeme Gott2015-06-09 05:42:40 -0400
commitbc30dcb08d9e6b0a73a6c10fbdeb50f146042168 (patch)
treed2c42c9af04aa6c61496634ffc28dac63df1ddac
downloadaur-bc30dcb08d9e6b0a73a6c10fbdeb50f146042168.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--cutemaze.install11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b39f61625b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cutemaze
+ pkgdesc = Top-down maze game
+ pkgver = 1.1.1
+ pkgrel = 2
+ url = http://gottcode.org/cutemaze/
+ install = cutemaze.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-svg
+ source = http://gottcode.org/cutemaze/cutemaze-1.1.1-src.tar.bz2
+ sha256sums = 3236d012af36a8390b86524e84d38baa40a12203a1e991c653203f3a23a7445d
+
+pkgname = cutemaze
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41a8ffd96cf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Graeme Gott <graeme@gottcode.org>
+
+pkgname=cutemaze
+pkgver=1.1.1
+pkgrel=2
+pkgdesc='Top-down maze game'
+arch=('i686' 'x86_64')
+url="http://gottcode.org/$pkgname/"
+license=('GPL3')
+depends=('qt5-base' 'qt5-svg')
+install="$pkgname.install"
+source=("http://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha256sums=('3236d012af36a8390b86524e84d38baa40a12203a1e991c653203f3a23a7445d')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/cutemaze.install b/cutemaze.install
new file mode 100644
index 000000000000..1c0de2e4fa61
--- /dev/null
+++ b/cutemaze.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}