summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2023-10-03 20:50:32 +0200
committerkleintux2023-10-03 20:50:32 +0200
commit299f456946024d5798e525407cd1180a4e6fdac9 (patch)
tree97968e4a94f9b22d9c719cd9b5a4573dd775c89e
parentea9cb3e462141201b12def5395bd4345d9bca71e (diff)
downloadaur-299f456946024d5798e525407cd1180a4e6fdac9.tar.gz
adopted. update to 3.0.2. changed source to github
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba4303ca011f..65d4bc9cb9de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = cutmp3
pkgdesc = Edit mp3 (and mp2) files without quality loss
- pkgver = 3.0.1
+ pkgver = 3.0.2
pkgrel = 1
- url = http://www.puchalla-online.de/cutmp3.html
- arch = i686
- arch = x86_64
+ url = https://www.puchalla-online.de/cutmp3.html
+ arch = any
license = GPL
depends = readline
- source = http://www.puchalla-online.de/cutmp3-3.0.1.tar.bz2
- md5sums = SKIP
+ source = https://github.com/tarjanm-movidius/cutmp3/archive/refs/tags/v3.0.2.tar.gz
+ sha256sums = 9b949de184570698b00c001f8762f4c507b6b4e86fe9ac362ca6250bcd8f08d2
pkgname = cutmp3
-
diff --git a/PKGBUILD b/PKGBUILD
index 80cd995926f8..ed826450554c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Petar Benke <makepkg@benke.co.uk>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Petar Benke <makepkg@benke.co.uk>
+
pkgname=cutmp3
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="Edit mp3 (and mp2) files without quality loss"
-arch=('i686' 'x86_64')
-url="http://www.puchalla-online.de/cutmp3.html"
+arch=('any')
+url="https://www.puchalla-online.de/cutmp3.html"
license=('GPL')
depends=('readline')
-source=("http://www.puchalla-online.de/$pkgname-$pkgver.tar.bz2")
-md5sums=('SKIP')
+source=("https://github.com/tarjanm-movidius/cutmp3/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9b949de184570698b00c001f8762f4c507b6b4e86fe9ac362ca6250bcd8f08d2')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
+ CFLAGS=-Wno-error=format-security
make
}
package() {
- cd "$pkgname-$pkgver"
- make PREFIX="$pkgdir/usr" install
+ cd "${pkgname}-${pkgver}"
+ make PREFIX="${pkgdir}/usr" install
}