summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2015-07-31 07:15:13 -0700
committerPatrick McCarty2015-07-31 07:15:13 -0700
commitbff27e5d1e7a1ce9a568cc0b8b4e009ad307fb3f (patch)
treeebf4fb6baef55120c7a7392b19735fe8fbe868a4
downloadaur-bff27e5d1e7a1ce9a568cc0b8b4e009ad307fb3f.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33289c2ffb87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cve-check-tool
+ pkgdesc = Automated tool for checking known (public) CVEs
+ pkgver = 5.2
+ pkgrel = 1
+ url = https://github.com/ikeydoherty/cve-check-tool
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = check
+ depends = curl
+ depends = json-glib
+ depends = libxml2
+ depends = sqlite
+ source = https://github.com/ikeydoherty/cve-check-tool/releases/download/v5.2/cve-check-tool-5.2.tar.xz
+ sha256sums = 779163a613b187007a1a2cd120658d5a3e5e419a02e618b593f7e84f362f10a0
+
+pkgname = cve-check-tool
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e812476e6e24
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+cve-check-tool-*.tar.xz
+*.pkg.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32225f05fed1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=cve-check-tool
+pkgver=5.2
+pkgrel=1
+pkgdesc="Automated tool for checking known (public) CVEs"
+arch=('i686' 'x86_64')
+url="https://github.com/ikeydoherty/cve-check-tool"
+license=('GPL2')
+depends=('curl' 'json-glib' 'libxml2' 'sqlite')
+makedepends=('check')
+source=(https://github.com/ikeydoherty/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz)
+sha256sums=('779163a613b187007a1a2cd120658d5a3e5e419a02e618b593f7e84f362f10a0')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}"/ install
+}
+
+# vim:set ts=2 sw=2 et: