summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWainer Vandelli2018-06-27 18:00:20 +0200
committerWainer Vandelli2018-06-27 18:06:28 +0200
commit119b66d53d874a0648ca494b61811c9e00f028f9 (patch)
treee221e60e1417cda485279cb5be3fe293553c00ea
parent65725a971d9c8be3be9ed548991880852906b8a0 (diff)
downloadaur-119b66d53d874a0648ca494b61811c9e00f028f9.tar.gz
Remove attr/xattr.h dependency
The header was removed recently from the attr package. More information here: http://git.savannah.nongnu.org/cgit/attr.git/commit/include?id=7921157890d07858d092f4003ca4c6bae9fd2c38
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--xattr.patch36
3 files changed, 47 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31ecee9f74c0..48ed1f3751bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cvmfs
pkgdesc = A client-server file system implemented in FUSE and developed to deliver software distributions onto virtual machines in a fast, scalable, and reliable way.
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://cernvm.cern.ch/portal/filesystem
install = cvmfs.install
arch = x86_64
@@ -24,10 +24,12 @@ pkgbase = cvmfs
source = settings.cmake
source = externals.patch
source = sqlite-scratch.patch
+ source = xattr.patch
md5sums = d46705e06267278fd3a65b277a6d9e16
md5sums = 20dc60c61077f4a3711463e8686d260d
md5sums = 109a95cab95276c1c19bc46b66f0906f
md5sums = 0ef4c858aa9648dcd46768991748eb06
+ md5sums = 08a46f14c08fe50b8d7cd33ec95ddda8
pkgname = cvmfs
diff --git a/PKGBUILD b/PKGBUILD
index d44313a014f1..21fc6b48b164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Konstantin Gizdov < arch at kge dot pw >
pkgname=cvmfs
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A client-server file system implemented in FUSE and developed to deliver software distributions onto virtual machines in a fast, scalable, and reliable way."
arch=('x86_64')
url="http://cernvm.cern.ch/portal/filesystem"
@@ -17,11 +17,13 @@ options=('!emptydirs')
source=("https://ecsft.cern.ch/dist/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
'settings.cmake'
'externals.patch'
- 'sqlite-scratch.patch')
+ 'sqlite-scratch.patch'
+ 'xattr.patch')
md5sums=('d46705e06267278fd3a65b277a6d9e16'
'20dc60c61077f4a3711463e8686d260d'
'109a95cab95276c1c19bc46b66f0906f'
- '0ef4c858aa9648dcd46768991748eb06')
+ '0ef4c858aa9648dcd46768991748eb06'
+ '08a46f14c08fe50b8d7cd33ec95ddda8')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -33,6 +35,9 @@ prepare() {
# Sqlite deprecated the SCRATCH configuration option
patch -Np1 -i "$srcdir/sqlite-scratch.patch"
+
+ # Do not use attr/xattr.h as it is not installed in Arch
+ patch -Np1 -i "$srcdir/xattr.patch"
}
build() {
diff --git a/xattr.patch b/xattr.patch
new file mode 100644
index 000000000000..7d2416072cce
--- /dev/null
+++ b/xattr.patch
@@ -0,0 +1,36 @@
+diff -Naur cvmfs-2.5.0.orig/CMakeLists.txt cvmfs-2.5.0/CMakeLists.txt
+--- cvmfs-2.5.0.orig/CMakeLists.txt 2018-06-27 17:53:00.709949213 +0200
++++ cvmfs-2.5.0/CMakeLists.txt 2018-06-27 17:53:45.610111417 +0200
+@@ -247,21 +247,6 @@
+ sys/wait.h sys/select.h pthread.h termios.h utime.h
+ signal.h errno.h dirent.h unistd.h fcntl.h netdb.h
+ syslog.h sys/resource.h execinfo.h poll.h pwd.h grp.h)
+-if (NOT MACOSX)
+- # Unfortunately, attr/xattr.h fails to compile without including sys/types.h
+- # before including attr/xattr.h (it uses size_t and ssize_t).
+- # CMake searches for include files by compiling a minimal *.c file like:
+- # #include <${SEARCHED_HEADER_FILE}>
+- # int main(int argc, char **argv) { return 0; }
+- #
+- # We pre-define the include guard of attr/xattr.h and thus still check, if the
+- # file is found by the compiler but mitigating the compiler errors caused by
+- # a standalone inclusion of attr/xattr.h
+- set (CMAKE_REQUIRED_DEFINITIONS "-D__XATTR_H__")
+- set (REQUIRED_HEADERS ${REQUIRED_HEADERS}
+- sys/statfs.h
+- attr/xattr.h)
+-endif (NOT MACOSX)
+
+ look_for_include_files (${REQUIRED_HEADERS})
+
+diff -Naur cvmfs-2.5.0.orig/cvmfs/platform_linux.h cvmfs-2.5.0/cvmfs/platform_linux.h
+--- cvmfs-2.5.0.orig/cvmfs/platform_linux.h 2018-06-27 17:53:00.719949251 +0200
++++ cvmfs-2.5.0/cvmfs/platform_linux.h 2018-06-27 17:53:03.899960637 +0200
+@@ -9,7 +9,6 @@
+
+ #include <sys/types.h> // contains ssize_t needed inside <attr/xattr.h>
+ #include <sys/xattr.h>
+-#include <attr/xattr.h> // NOLINT(build/include_alpha)
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>