summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-01 19:26:19 -0400
committeréclairevoyant2023-05-01 19:26:19 -0400
commite47147c6b6b8593457951132c6f2149ddf8fd8c5 (patch)
treea170e41a41f10ed3cdb48569559af7fbef8b3e06
parent100f0f3897c3d0d6fb14113ec5c8d4a6529feb33 (diff)
downloadaur-cvt12-git.tar.gz
cvt12-git: fix quoting, pkgver; bump epoch; respect compilation flags
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 32 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd80853a2f19..09e20a6ab332 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = cvt12-git
- pkgdesc = Generate mode timings using the CVT v1.2 or CVT v1.1 Timing Standards
- pkgver = 1.2
+ pkgdesc = Generate mode timings using the CVT v1.2/v1.1 Timing Standards
+ pkgver = r17.6f66135
pkgrel = 1
+ epoch = 1
url = https://github.com/kevinlekiller/cvt_modeline_calculator_12
arch = i686
arch = x86_64
- license = custom
- makedepends = gcc>=4.8.0,
+ license = BSD
makedepends = git
+ depends = glibc
source = git+https://github.com/kevinlekiller/cvt_modeline_calculator_12.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = cvt12-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 810ea2027efd..cb565473073e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
+# Maintainer: éclairevoyant
-# Maintainer: Nathan Lowe <techwiz96@gmail.com>
-# Upstream URL: https://github.com/kevinlekiller/cvt_modeline_calculator_12
-#
-# For improvements/fixes to this package, please send a pull request:
-# https://github.com/nlowe/aur-cvt12
-
+_gitname=cvt_modeline_calculator_12
pkgname=cvt12-git
-pkgver=1.2
+pkgver=r17.6f66135
pkgrel=1
-pkgdesc='Generate mode timings using the CVT v1.2 or CVT v1.1 Timing Standards'
-arch=('i686' 'x86_64')
-url='https://github.com/kevinlekiller/cvt_modeline_calculator_12'
-license=('custom')
-makedepends=('gcc>=4.8.0', 'git')
-source=("git+${url}.git")
-sha256sums=('SKIP')
+epoch=1
+pkgdesc='Generate mode timings using the CVT v1.2/v1.1 Timing Standards'
+arch=(i686 x86_64)
+url="https://github.com/kevinlekiller/$_gitname"
+depends=(glibc)
+license=(BSD)
+makedepends=(git)
+source=("git+$url.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd $srcdir/cvt_modeline_calculator_12
- gcc cvt12.c -O2 -o cvt12 -lm -Wall
+ cd $_gitname
+ gcc $CFLAGS cvt12.c -O2 -o cvt12 -lm -Wall $LDFLAGS
}
package() {
- install -Dm755 "$srcdir/cvt_modeline_calculator_12/cvt12" "$pkgdir/usr/bin/cvt12"
-
- mkdir -p $pkgdir/usr/share/licenses/cvt12
- cat <<'EOF' >> $pkgdir/usr/share/licenses/cvt12/LICENSE
+ install -Dm755 $_gitname/cvt12 -t "$pkgdir/usr/bin/"
+ install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/cvt12/LICENSE" <<eof
Copyright (c) 2001, Andy Ritger aritger@nvidia.com
All rights reserved.
@@ -72,5 +73,5 @@ its contributors assume no responsibility for errors or omissions,
and make no warranties, expressed or implied, of functionality
of suitability for any purpose. The sample code contained within
this standard may be used without restriction.
-EOF
+eof
}