summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 11:24:42 +0200
committerwillemw122015-06-08 11:24:42 +0200
commit9784272856132bc34fc74e44945daf58dcbe0409 (patch)
treea702a8fa09b87f46b040dafd9d7e7e8b0e3d9ee3
downloadaur-9784272856132bc34fc74e44945daf58dcbe0409.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
-rw-r--r--bsetrootconfig5
-rw-r--r--cwallpaper.install20
-rw-r--r--feh_config5
-rw-r--r--hsetconfig5
6 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3214e7f5520b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cwallpaper
+ pkgdesc = Front-end for fbsetbg, esetroot, feh and other wallpaper changers
+ pkgver = 0.3.2
+ pkgrel = 2
+ url = http://cwallpaper.sourceforge.net/index.php
+ install = cwallpaper.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automake
+ makedepends = autoconf
+ depends = gtk2
+ conflicts = cwallpaper-fltk
+ source = http://downloads.sourceforge.net/cwallpaper/cwallpaper-0.3.2.tar.gz
+ source = bsetrootconfig
+ source = feh_config
+ source = hsetconfig
+ md5sums = 85ca1399e8960097cbb6580dceb47163
+ md5sums = 707ddfe918170b2e9ac05c7be8d35cd2
+ md5sums = 24dd59429b9a39b99ba294b1525c47db
+ md5sums = 376a927d5f129efe19dd8a69c76dc583
+
+pkgname = cwallpaper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e66a0e0bd4bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Murtuza Akhtari <inxsible at gmail dot com>
+
+pkgname=cwallpaper
+pkgver=0.3.2
+pkgrel=2
+pkgdesc="Front-end for fbsetbg, esetroot, feh and other wallpaper changers"
+arch=('i686' 'x86_64')
+url="http://cwallpaper.sourceforge.net/index.php"
+license=('GPL')
+depends=('gtk2')
+conflicts=('cwallpaper-fltk')
+makedepends=('automake' 'autoconf')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ bsetrootconfig feh_config hsetconfig)
+md5sums=('85ca1399e8960097cbb6580dceb47163'
+ '707ddfe918170b2e9ac05c7be8d35cd2'
+ '24dd59429b9a39b99ba294b1525c47db'
+ '376a927d5f129efe19dd8a69c76dc583')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ # Extra config examples
+ install -m644 -D bsetrootconfig "$pkgdir/usr/share/cwallpaper/bsetrootconfig"
+ install -m644 -D feh_config "$pkgdir/usr/share/cwallpaper/feh_config"
+ install -m644 -D hsetconfig "$pkgdir/usr/share/cwallpaper/hsetconfig"
+
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ chmod a+x "$pkgdir/usr/share/cwallpaper/"*.sh
+}
+
diff --git a/bsetrootconfig b/bsetrootconfig
new file mode 100644
index 000000000000..3b2765fabb3b
--- /dev/null
+++ b/bsetrootconfig
@@ -0,0 +1,5 @@
+program: bsetroot
+scale: -full
+tile: -tile
+center: -center
+default: s
diff --git a/cwallpaper.install b/cwallpaper.install
new file mode 100644
index 000000000000..6930587aaad1
--- /dev/null
+++ b/cwallpaper.install
@@ -0,0 +1,20 @@
+post_install() {
+ #echo "*******************************************************"
+ echo ":: man cwallpaper for configration instructions"
+ echo "::"
+ echo ":: For example:"
+ echo ":: Generate a wallpaper list in file ~/config/cwallpaper/wallpapers:"
+ echo ":: $ /usr/share/cwallpaper/makeList.sh ~/Pictures/"
+ echo ":: Copy one of the config files:"
+ echo ":: $ cp /usr/share/cwallpaper/fex_config ~/.config/cwallpaper/config"
+ echo ":: Edit 'config' for your root wallpaper changer, if necessary."
+ echo ":: Select a wallpaper:"
+ echo ":: $ cwallpaper"
+ echo ":: Put 'cwallpaper -l' in your login script to load the last selected wallpaper."
+ #echo "*******************************************************"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
diff --git a/feh_config b/feh_config
new file mode 100644
index 000000000000..b3fadfe859a9
--- /dev/null
+++ b/feh_config
@@ -0,0 +1,5 @@
+program: feh
+scale: --bg-scale
+center:--bg-center
+tile: --bg-tile
+default: s
diff --git a/hsetconfig b/hsetconfig
new file mode 100644
index 000000000000..fbb11e0219da
--- /dev/null
+++ b/hsetconfig
@@ -0,0 +1,5 @@
+program: hsetroot
+scale: -full
+center: -center
+tile: -tile
+default: s \ No newline at end of file