summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraptor81342021-04-26 14:40:35 -0700
committerraptor81342021-04-26 14:40:35 -0700
commit61fa9accef2d1dc25d681ac390b4707feb93683c (patch)
treefbeae46eb9e04914117145073d66d2b7559d50fb
downloadaur-61fa9accef2d1dc25d681ac390b4707feb93683c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c7c2296e19d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cweather
+ pkgdesc = Simple weather utility written in C - read the source code for more info
+ pkgver = 0.1.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cjson
+ depends = curl
+ optdepends = nerd-fonts: for the expanded icon set
+ provides = cweather
+ source = git+https://github.com/raptor8134/cweather.git
+ md5sums = SKIP
+
+pkgname = cweather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c9edc610038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=cweather
+pkgbase=cweather
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Simple weather utility written in C - read the source code for more info"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('cjson' 'curl')
+optdepends=('nerd-fonts: for the expanded icon set')
+provides=('cweather')
+source=("git+https://github.com/raptor8134/cweather.git")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgbase}
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cd ${srcdir}/${pkgbase}
+ make DESTDIR="${pkgdir}/" install
+}