summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2018-01-03 10:06:23 +0100
committerDavid Runge2018-01-03 10:06:23 +0100
commitc9ebd0fd3bb5026d7b3d31cea0549fefe72972b2 (patch)
tree1a7f9da425bab2c2c40aca88c7281688201933f3
downloadaur-c9ebd0fd3bb5026d7b3d31cea0549fefe72972b2.tar.gz
PKGBUILD: Dropping cwiid from community due to unmaintained upstream and being superseeded by XWiimote.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
-rw-r--r--cwiid.install10
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e00c002e0ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cwiid
+ pkgdesc = Linux Nintendo Wiimote interface
+ pkgver = 0.6.00+svn201
+ pkgrel = 3
+ url = http://abstrakraft.org/cwiid
+ install = cwiid.install
+ arch = x86_64
+ license = GPL
+ depends = bluez-libs
+ depends = gtk2
+ depends = python2
+ source = https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz
+ sha512sums = 25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b
+
+pkgname = cwiid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7635ad6365c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 271927 2017-12-02 20:55:03Z dvzrv $
+# Maintainer: David Runge <dave@sleepmap.de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: Wieland Hoffmann <the_mineo@web.de>
+# Contributor: Birger Moellering <bmoellering@googlemail.com>
+# 2018/01/03: <dropped from community; upstream dead, unneeded>
+# 2012/06/05: <added into community as supercollider dependency>
+# 2012/03/21: <dropped from community; broken + see bug #28344>
+
+pkgname=cwiid
+pkgver=0.6.00+svn201
+pkgrel=3
+pkgdesc="Linux Nintendo Wiimote interface"
+arch=('x86_64')
+url="http://abstrakraft.org/cwiid"
+depends=('bluez-libs' 'gtk2' 'python2')
+license=('GPL')
+install="$pkgname.install"
+source=("https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz")
+sha512sums=('25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b')
+
+prepare() {
+ cd "${pkgname}-svn_history"
+ # fixing ldconfig use in configure
+ sed -i '/ldconfig/s/WITH/ENABLE/' configure.ac
+ autoreconf -fi
+}
+
+build() {
+ cd "${pkgname}-svn_history"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-python=python2 \
+ --enable-ldconfig=no
+
+ LDFLAGS+=" -pthread -lpthread -lbluetooth" \
+ make
+}
+
+package() {
+ cd "${pkgname}-svn_history"
+ make DESTDIR="${pkgdir}" install
+
+ # wminput README
+ install -Dm644 wminput/README \
+ "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cwiid.install b/cwiid.install
new file mode 100644
index 000000000000..05e698be70c7
--- /dev/null
+++ b/cwiid.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "==> In order to use wminput ensure you load the uinput kernel"
+ echo "==> module and have assigned correct access to /dev/uinput"
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: