summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvaldar2015-07-03 14:45:35 +0100
committervaldar2015-07-03 14:45:35 +0100
commit1ddabd4a56dfd1aa0f617863a86060c2405ecb4b (patch)
tree3c7013c63e52091c9f23e442379228fd56060e71
downloadaur-1ddabd4a56dfd1aa0f617863a86060c2405ecb4b.tar.gz
Initial commit migration to aur4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD74
-rw-r--r--cwiid.install16
-rw-r--r--fix_libbluethoot.patch25
4 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e33aec978af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cwiid-git
+ pkgdesc = Cwiid-git is the bleeding edge version of a wiimote's driver and utility tools
+ pkgver = 20130619
+ pkgrel = 2
+ url = http://github.com/abstrakraft/cwiid
+ install = cwiid.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = bluez4
+ depends = gtk2
+ depends = python2
+ provides = cwiid
+ provides = cwiid-svn
+ conflicts = cwiid
+ conflicts = cwiid-svn
+ source = fix_libbluethoot.patch
+ md5sums = d92745847f5ba534c2914be1d2b36092
+
+pkgname = cwiid-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5a89a0e7901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+#Contributor:Andrea Tarocchi <valdar@email.it>
+pkgname=cwiid-git
+#pkgver=`date +%Y%m%d`
+pkgver=20130619
+pkgrel=2
+pkgdesc="Cwiid-git is the bleeding edge version of a wiimote's driver and utility tools"
+arch=(i686 x86_64)
+url="http://github.com/abstrakraft/cwiid"
+license=('GPL')
+
+depends=('bluez4' 'gtk2' 'python2')
+makedepends=('git' 'make')
+conflicts=('cwiid' 'cwiid-svn')
+provides=('cwiid' 'cwiid-svn')
+install=cwiid.install
+source=(fix_libbluethoot.patch)
+md5sums=('d92745847f5ba534c2914be1d2b36092')
+
+_gitroot=git://github.com/abstrakraft/cwiid.git
+_gitname=cwiid
+_builddir=$_gitname-build
+
+build() {
+ export PYTHON=python2
+ export LDFLAGS=
+
+ cd $srcdir/
+ msg "Connecting to github.com GIT server...."
+ if [ -d $srcdir/$_gitname ] ; then
+ pushd $_gitname && git pull origin && popd
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+ rm -rf $_gitname-build
+ git clone $_gitname $_gitname-build
+
+ cd $_builddir
+
+ git am --signoff < ../../fix_libbluethoot.patch
+
+ aclocal
+ autoreconf
+ ./configure --prefix=/usr --sysconfdir=/etc --with-python=python`python2 --version 2>&1 | cut -d ' ' -f2` --disable-ldconfig
+# OLD CONFIG OPTIONS:
+# usefull options: LDFLAGS=-L/usr/lib/python2.7
+
+ make
+# OLD MAKE OPTIONS:
+# CPPFLAGS=-I/usr/include/python2.7 || return 1
+}
+package() {
+ cd $srcdir/
+ cd $_builddir
+ make DESTDIR="${pkgdir}" install
+
+# OLD BUILD WAY:
+# aclocal
+# autoreconf
+
+# ./configure --disable-ldconfig --prefix=/usr --sysconfdir=/etc --with-cwiid-plugins-dir=/lib/cwiid/plugins
+# make LDFLAGS=-L../libcwiid || return 1
+
+# install -d $startdir/pkg/usr/bin
+# install -d $startdir/pkg/etc
+# install -d $startdir/pkg/usr/lib
+# install -d $startdir/pkg/usr/include
+
+# make install LDFLAGS=-L../libcwiid prefix=$startdir/pkg/usr sysconfdir=$startdir/pkg/etc install
+
+# install -D -m644 ./wminput/README $pkgdir/usr/share/doc/cwiid/wminput
+} \ No newline at end of file
diff --git a/cwiid.install b/cwiid.install
new file mode 100644
index 000000000000..5dc5fafc48de
--- /dev/null
+++ b/cwiid.install
@@ -0,0 +1,16 @@
+# arg 1: the new package version
+post_install() {
+echo -e "Note:"
+echo -e "\033[1;31m==> In order to use wminput you have to load the uinput kernel module:\033[0m"
+echo -e "\033[1;31m==> modprobe uinput (as root)\033[0m"
+echo -e "\033[1;31m==> and you have to assign correct right acces to /dev/uinput\033[0m"
+echo -e "\033[1;31m==> PLEAS READ THE DOC FILE /usr/share/doc/cwiid/wminput\033[0m"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $* \ No newline at end of file
diff --git a/fix_libbluethoot.patch b/fix_libbluethoot.patch
new file mode 100644
index 000000000000..21696bdd3ce9
--- /dev/null
+++ b/fix_libbluethoot.patch
@@ -0,0 +1,25 @@
+From f6ea62965b27392212895be20c7d865291a249f6 Mon Sep 17 00:00:00 2001
+From: valdar <valdar@email.it>
+Date: Sun, 8 Jul 2012 15:36:49 +0000
+Subject: [PATCH] Added -llibthool on wmdemo.
+
+---
+ wmdemo/Makefile.in | 2 +-
+ 1 file modificato, 1 inserzione(+). 1 rimozione(-)
+
+diff --git a/wmdemo/Makefile.in b/wmdemo/Makefile.in
+index 56aed58..1eccc02 100644
+--- a/wmdemo/Makefile.in
++++ b/wmdemo/Makefile.in
+@@ -8,7 +8,7 @@ SOURCES = wmdemo.c
+
+ CFLAGS += -I@top_builddir@/libcwiid
+ LDFLAGS += -L@top_builddir@/libcwiid
+-LDLIBS += -lcwiid
++LDLIBS += -lcwiid -lbluetooth
+ INST_DIR = @bindir@
+
+ include $(COMMON)/include/app.mak
+--
+1.7.11.1
+