summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzer0-x2023-03-07 07:39:49 +0300
committerzer0-x2023-03-07 07:39:49 +0300
commit08355441aa880f901ec8f14dd9e7b14464c70309 (patch)
tree125dae17daf4a78afa38c931ba9e549f76e3b02a
parentf084e8bd21542bfaa7f94ebce81b45414b71fd57 (diff)
downloadaur-cwitch.tar.gz
Update to v0.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e084a45a6455..8670819b2308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cwitch
- pkgdesc = CLI tool to watch Twitch live streams and videos with the help of mpv and youtube-dl.
- pkgver = 0.2.1
+ pkgdesc = CLI tool to watch Twitch live streams and videos with the help of mpv and yt-dlp.
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/zer0-x/cwitch
arch = any
@@ -8,9 +8,9 @@ pkgbase = cwitch
makedepends = python-setuptools
depends = mpv
depends = python-mpv
- depends = youtube-dl
+ depends = yt-dlp
depends = python-prompt_toolkit
- source = cwitch-0.2.1.tar.gz::https://github.com/zer0-x/cwitch/archive/refs/tags/v0.2.1.tar.gz
- sha512sums = 8c22c93c2d8fd9f7fb1c0bd73a7bc10f80985feb0b85dd366f2e3e71e9d9031f05a289b83e5ac94b347bfbc22a8e0f85e0e761b47ee84f732bd946ef507fe595
+ source = cwitch-0.3.0.tar.gz::https://github.com/zer0-x/cwitch/archive/refs/tags/v0.3.0.tar.gz
+ sha512sums = a45735c00868a65b177fcddecdd1326e9b14572f1353f99eb510a7a983dad0d220c5150db71bdeba6c97369e038449fbf50e2a7d1f8f4241afa12c8955ad477c
pkgname = cwitch
diff --git a/PKGBUILD b/PKGBUILD
index 0d5b73d3ffcb..0bab8ed3e0a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: zer0-x < Matrix: "@zer0-x:kde.org" >
pkgname="cwitch"
-pkgver="0.2.1"
+pkgver="0.3.0"
pkgrel=1
-pkgdesc="CLI tool to watch Twitch live streams and videos with the help of mpv and youtube-dl."
+pkgdesc="CLI tool to watch Twitch live streams and videos with the help of mpv and yt-dlp."
arch=('any')
url="https://github.com/zer0-x/cwitch"
license=('GPL3')
-depends=('mpv' 'python-mpv' 'youtube-dl' 'python-prompt_toolkit')
+depends=('mpv' 'python-mpv' 'yt-dlp' 'python-prompt_toolkit')
makedepends=('python-setuptools')
# checkdepends = ('python-pytest')
-# changelog=
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/zer0-x/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('8c22c93c2d8fd9f7fb1c0bd73a7bc10f80985feb0b85dd366f2e3e71e9d9031f05a289b83e5ac94b347bfbc22a8e0f85e0e761b47ee84f732bd946ef507fe595')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=("a45735c00868a65b177fcddecdd1326e9b14572f1353f99eb510a7a983dad0d220c5150db71bdeba6c97369e038449fbf50e2a7d1f8f4241afa12c8955ad477c")
build() {
cd "${pkgname}-${pkgver}"