summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzer0-x2022-10-08 01:20:38 +0300
committerzer0-x2022-10-08 01:20:38 +0300
commitf4bdac3b4fe144445b2f99b57bf9355d9aa291d9 (patch)
tree464a0a600a370f242e0bfc64735d17b621736fa1
downloadaur-f4bdac3b4fe144445b2f99b57bf9355d9aa291d9.tar.gz
Fist commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84f264727ffe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cwitch
+ pkgdesc = CLI tool to watch Twitch live streams and videos with the help of mpv and youtube-dl.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/zer0-x/cwitch
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = mpv
+ depends = youtube-dl
+ depends = python-prompt_toolkit
+ source = cwitch-0.2.1.tar.gz::https://github.com/zer0-x/cwitch/archive/refs/tags/v0.2.1.tar.gz
+ sha512sums = 8c22c93c2d8fd9f7fb1c0bd73a7bc10f80985feb0b85dd366f2e3e71e9d9031f05a289b83e5ac94b347bfbc22a8e0f85e0e761b47ee84f732bd946ef507fe595
+
+pkgname = cwitch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b42b995f6795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: zer0-x
+
+pkgname="cwitch"
+pkgver="0.2.1"
+pkgrel=1
+pkgdesc="CLI tool to watch Twitch live streams and videos with the help of mpv and youtube-dl."
+arch=('any')
+url="https://github.com/zer0-x/cwitch"
+license=('GPL3')
+depends=('mpv' 'youtube-dl' 'python-prompt_toolkit')
+makedepends=('python-setuptools')
+# checkdepends = ('python-pytest')
+# changelog=
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/zer0-x/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('8c22c93c2d8fd9f7fb1c0bd73a7bc10f80985feb0b85dd366f2e3e71e9d9031f05a289b83e5ac94b347bfbc22a8e0f85e0e761b47ee84f732bd946ef507fe595')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ python3 setup.py build
+}
+
+# check() {
+# cd "${pkgname}-${pkgver}"
+#
+# pytest
+# }
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ # TODO: Install shell completions when they are avialable in the source.
+
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}