summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2022-08-15 13:51:10 -0600
committerBrian Bidulock2022-08-15 13:51:10 -0600
commit3d2c69f008f5d14ca39ba24ee995140b5bcc28b9 (patch)
tree40c991bd42d156264c3ddca037e607ecdf8e4240
parentbf5b4d9615363f6f50642e36c142ba332cc5fe83 (diff)
downloadaur-3d2c69f008f5d14ca39ba24ee995140b5bcc28b9.tar.gz
new repo
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d24c294fe608..3d622a5259de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cwm-git
pkgdesc = OpenBSD fork of calmwm, a clean and lightweight window manager
- pkgver = 20160402
+ pkgver = 20220430
pkgrel = 1
url = http://www.openbsd.org/cgi-bin/man.cgi?query=cwm&sektion=1
arch = i686
@@ -13,10 +13,9 @@ pkgbase = cwm-git
depends = libxinerama
provides = cwm
conflicts = cwm
- source = git://github.com/chneukirchen/cwm.git#branch=linux
+ source = cwm-git::git+https://github.com/leahneukirchen/cwm.git#branch=linux
source = cwm.desktop
md5sums = SKIP
md5sums = 42530ce5a23fc5f9088d891e325d99bd
pkgname = cwm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4f3fc3d5ac60..92b8e9457fdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Christian Neukirchen <chneukirchen@gmail.com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
pkgname=cwm-git
-pkgver=20160402
+pkgver=20220430
pkgrel=1
pkgdesc="OpenBSD fork of calmwm, a clean and lightweight window manager"
arch=('i686' 'x86_64')
@@ -10,22 +11,22 @@ depends=('libxft' 'libxrandr' 'libxinerama')
makedepends=('git' 'pkg-config')
conflicts=('cwm')
provides=('cwm')
-source=('git://github.com/chneukirchen/cwm.git#branch=linux' 'cwm.desktop')
+source=("$pkgname::git+https://github.com/leahneukirchen/cwm.git#branch=linux" 'cwm.desktop')
md5sums=('SKIP'
'42530ce5a23fc5f9088d891e325d99bd')
pkgver() {
- cd "$srcdir/cwm"
+ cd $pkgname
git log -1 --format="%cd" --date=short | sed 's|-||g'
}
build() {
- cd "$srcdir/cwm"
+ cd $pkgname
make
}
package() {
- cd "$srcdir/cwm"
+ cd $pkgname
make DESTDIR="${pkgdir}" PREFIX=/usr install
install -D -m644 "${srcdir}/cwm.desktop" "${pkgdir}/usr/share/xsessions/cwm.desktop"
install -D -m644 <(sed -n '/Copyright/,/PERFORMANCE/p' <calmwm.c) "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"