summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2016-04-16 10:45:43 -0400
committerM.Reynolds2016-04-16 10:45:43 -0400
commit39fb441dcc5120158c7540ab06e988b6ddb70738 (patch)
tree37a0a210e884c6bc965b30ad08656e24e9074ceb
downloadaur-39fb441dcc5120158c7540ab06e988b6ddb70738.tar.gz
Initial package upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a27d87b5b05a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cx23885-firmware
+ pkgdesc = Hauppauge hvr1800 tv-tuner card firmware.
+ pkgver = 2016.04.16
+ pkgrel = 1
+ url = http://permalink.gmane.org/gmane.linux.drivers.video-input-infrastructure/46978
+ arch = any
+ license = custom
+ depends = linux-firmware
+ source = http://steventoth.net/linux/hvr1800/HVR-12x0-14x0-17x0_1_25_25271_WHQL.zip
+ source = http://steventoth.net/linux/hvr1800/extract.sh
+ source = http://steventoth.net/linux/hvr1800/readme.txt
+ sha256sums = ccbe3bc8b8545ecf00cf3fc47af1b33f312a6f2e873a3e29ce1e8b82adef49d9
+ sha256sums = 8c231e54c08920b144df44017db111835c557fca7c4082c412eb6fa9d413be5a
+ sha256sums = b6d27d2e6c6d1101556ede4539d672ba6b780462a171a2f9f445a09107228285
+
+pkgname = cx23885-firmware
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8012bbd13f94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
+
+pkgname=cx23885-firmware
+pkgver=2016.04.16
+pkgrel=1
+pkgdesc="Hauppauge hvr1800 tv-tuner card firmware."
+arch=('any')
+url="http://permalink.gmane.org/gmane.linux.drivers.video-input-infrastructure/46978"
+license=('custom')
+depends=('linux-firmware')
+source=('http://steventoth.net/linux/hvr1800/HVR-12x0-14x0-17x0_1_25_25271_WHQL.zip'
+ 'http://steventoth.net/linux/hvr1800/extract.sh'
+ 'http://steventoth.net/linux/hvr1800/readme.txt')
+sha256sums=('ccbe3bc8b8545ecf00cf3fc47af1b33f312a6f2e873a3e29ce1e8b82adef49d9'
+ '8c231e54c08920b144df44017db111835c557fca7c4082c412eb6fa9d413be5a'
+ 'b6d27d2e6c6d1101556ede4539d672ba6b780462a171a2f9f445a09107228285')
+
+package() {
+ _systemdbasedir="$pkgdir/usr/lib/firmware"
+
+ cd "$srcdir"
+ sh extract.sh
+ install -Dm644 v4l-cx23885-enc.fw "$_systemdbasedir/v4l-cx23885-enc.fw"
+
+ # The below file is owned by the package linux-firmware and so should not be extracted
+ # install -Dm644 v4l-cx23885-avcore-01.fw "$_systemdbasedir/v4l-cx23885-avcore-01.fw"
+ }