summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoses Narrow2020-02-19 16:31:29 -0600
committerMoses Narrow2020-02-19 16:31:29 -0600
commitfb4fd21ffdf65542a211943a035be5316fbf3933 (patch)
tree1f08fad4962c1e8fa0457744e552e8be74c466ab
parent26f62e92b9c56c94914107568c55cbbe09762e0e (diff)
downloadaur-fb4fd21ffdf65542a211943a035be5316fbf3933.tar.gz
update signature checking & dependancies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.sigbin566 -> 566 bytes
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b9440828b0c..4188fe55c6af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = cxo
pkgdesc = CX Object Storage System for the Skycoin Blockchain
pkgver = 3.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/skycoinproject/cxo
arch = any
makedepends = go
makedepends = dep
+ makedepends = skycoin-keyring
source = https://github.com/skycoinproject/cxo/archive/v3.1.0.tar.gz
- source = https://raw.githubusercontent.com/0pcom/skycoin_archlinux_packages/master/key
+ source = PKGBUILD.sig
+ validpgpkeys = DE08F924EEE93832DABC642CA8DC761B1C0C0CFC
+ validpgpkeys = 98F934F04F9334B81DFA3398913BBD5206B19620
sha256sums = e4fc5221d89b0f548a0093c944829c0b3e94f96efcc339effc5fea34f4accbd3
- sha256sums = 41c0a4a42ae64479b008392053f4a947618acd6bb9c3ed2672dafdb2453caa14
+ sha256sums = SKIP
pkgname = cxo
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index dcb6ae62d946..6f9a36d9b376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,18 @@ githuborg=skycoinproject
pkgdesc="CX Object Storage System for the Skycoin Blockchain"
pkgver=3.1.0
pkggopath="github.com/${githuborg}/${pkgname1}"
-pkgrel=3
+pkgrel=4
arch=('any')
url="https://${pkggopath}"
license=()
-makedepends=('go' 'dep')
+makedepends=('go' 'dep' 'skycoin-keyring')
source=("https://${pkggopath}/archive/v${pkgver}.tar.gz"
-"https://raw.githubusercontent.com/0pcom/skycoin_archlinux_packages/master/key")
+"PKGBUILD.sig")
sha256sums=('e4fc5221d89b0f548a0093c944829c0b3e94f96efcc339effc5fea34f4accbd3'
-'41c0a4a42ae64479b008392053f4a947618acd6bb9c3ed2672dafdb2453caa14')
+'SKIP')
+validpgpkeys=('DE08F924EEE93832DABC642CA8DC761B1C0C0CFC' # Moses Narrow <moe_narrow@use.startmail.com>
+ '98F934F04F9334B81DFA3398913BBD5206B19620') #iketheadore skycoin <luxairlake@protonmail.com>
+
prepare() {
gpg --import key
@@ -31,12 +34,22 @@ prepare() {
msg2 'installing go dependencies'
#dep init
dep ensure
- cd cmd
- go install -v ./...
+ cmddir=${srcdir}/go/src/github.com/${githuborg}/${pkgname1}/cmd
+ #using go build for determinism
+ cd ${cmddir}/cxocli
+ msg2 'building cxocli binary'
+ go build -trimpath -ldflags '-extldflags ${LDFLAGS}' -ldflags=-buildid= -o $GOBIN/ .
+ cd ${cmddir}/cxod
+ msg2 'building cxod binary'
+ go build -trimpath -ldflags '-extldflags ${LDFLAGS}' -ldflags=-buildid= -o $GOBIN/ .
+ #binary transparency
+ cd $GOBIN
+ msg2 'binary sha256sums'
+ sha256sum $(ls)
+
}
package() {
- msg2 'installing CXO'
options=(!strip staticlibs)
mkdir -p ${pkgdir}/usr/bin
mkdir -p ${pkgdir}/usr/lib/${projectname}/go/bin
diff --git a/PKGBUILD.sig b/PKGBUILD.sig
index 250a4663240a..d20f924ac539 100644
--- a/PKGBUILD.sig
+++ b/PKGBUILD.sig
Binary files differ