summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-05-18 15:27:39 +0200
committerAlexander F. Rødseth2021-05-18 15:27:39 +0200
commit4cf282cb42fccc090fd85b041c3f9ede37e28752 (patch)
tree1151756bf9f7ee4796617898702abb195ce46bf3
parentd2c74c803db28db7f380e71fd31ac7a9a1d2e70a (diff)
downloadaur-4cf282cb42fccc090fd85b041c3f9ede37e28752.tar.gz
New release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfe89b9bd6d1..a4c9dc603d2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cxx
pkgdesc = Easily compile a main.cpp file written in C++20
- pkgver = 3.2.6
+ pkgver = 3.2.8
pkgrel = 1
url = https://github.com/xyproto/cxx
arch = any
@@ -8,16 +8,16 @@ pkgbase = cxx
makedepends = git
depends = scons
optdepends = ccache: For faster builds
- optdepends = lldb: For debugging
optdepends = clang: For clang-format and for clang++
- optdepends = mingw-w64-gcc: For compiling 64-bit Windows executables
- optdepends = wine: For running 64-bit Windows exectuables
- optdepends = valgrind: For tracing calls and profiling
- optdepends = gprof2dot: For visualizing profiling information
optdepends = graphviz: For visualizing profiling information
+ optdepends = gprof2dot: For visualizing profiling information
optdepends = kcachegrind: For visualizing profiling information
- source = git+https://github.com/xyproto/cxx#commit=415a6afa440b1cec6fb7f068a3369e6ae0a0e9de
- sha256sums = SKIP
+ optdepends = lldb: For debugging
+ optdepends = mingw-w64-gcc: For compiling 64-bit Windows executables
+ optdepends = valgrind: For tracing calls and profiling
+ optdepends = wine: For running 64-bit Windows exectuables
+ source = git+https://github.com/xyproto/cxx#commit=dcb95022c4deb4d70ca1ca4d9050eff535a54eb1
+ b2sums = SKIP
pkgname = cxx
diff --git a/PKGBUILD b/PKGBUILD
index b9ce1054efcd..5995a71aac15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=cxx
-pkgver=3.2.6
+pkgver=3.2.8
pkgrel=1
pkgdesc='Easily compile a main.cpp file written in C++20'
arch=(any)
@@ -10,19 +10,17 @@ license=(MIT)
makedepends=(git)
depends=(scons)
optdepends=('ccache: For faster builds'
- 'lldb: For debugging'
'clang: For clang-format and for clang++'
+ 'graphviz: For visualizing profiling information'
+ 'gprof2dot: For visualizing profiling information'
+ 'kcachegrind: For visualizing profiling information'
+ 'lldb: For debugging'
'mingw-w64-gcc: For compiling 64-bit Windows executables'
- 'wine: For running 64-bit Windows exectuables'
'valgrind: For tracing calls and profiling'
- 'gprof2dot: For visualizing profiling information'
- 'graphviz: For visualizing profiling information'
- 'kcachegrind: For visualizing profiling information')
-source=("git+$url#commit=415a6afa440b1cec6fb7f068a3369e6ae0a0e9de") # tag: 3.2.6
-sha256sums=('SKIP')
+ 'wine: For running 64-bit Windows exectuables')
+source=("git+$url#commit=dcb95022c4deb4d70ca1ca4d9050eff535a54eb1") # tag: 3.2.8
+b2sums=('SKIP')
package() {
DESTDIR="$pkgdir" make -C $pkgname install
}
-
-# getver: github.com/xyproto/cxx/releases