summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-08-03 16:14:14 +0200
committerAlexander F. Rødseth2021-08-03 16:14:14 +0200
commit4f8e789a2a12d441445ab095199a3957cf5f2a9c (patch)
treef88236f92ccaccdc2c859c6ff705260c4fe2f36e
parent4cf282cb42fccc090fd85b041c3f9ede37e28752 (diff)
downloadaur-4f8e789a2a12d441445ab095199a3957cf5f2a9c.tar.gz
Update package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4c9dc603d2a..80749e6611e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cxx
- pkgdesc = Easily compile a main.cpp file written in C++20
- pkgver = 3.2.8
+ pkgdesc = Compile C++ code by detecting flags and includes automatically
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/xyproto/cxx
arch = any
@@ -16,8 +16,7 @@ pkgbase = cxx
optdepends = mingw-w64-gcc: For compiling 64-bit Windows executables
optdepends = valgrind: For tracing calls and profiling
optdepends = wine: For running 64-bit Windows exectuables
- source = git+https://github.com/xyproto/cxx#commit=dcb95022c4deb4d70ca1ca4d9050eff535a54eb1
+ source = git+https://github.com/xyproto/cxx#commit=bac4780e070d7168a44e9f4ce596d27614eda02e
b2sums = SKIP
pkgname = cxx
-
diff --git a/PKGBUILD b/PKGBUILD
index 5995a71aac15..125d5e9d59bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=cxx
-pkgver=3.2.8
+pkgver=3.3.0
pkgrel=1
-pkgdesc='Easily compile a main.cpp file written in C++20'
+pkgdesc='Compile C++ code by detecting flags and includes automatically'
arch=(any)
url='https://github.com/xyproto/cxx'
license=(MIT)
@@ -18,8 +18,8 @@ optdepends=('ccache: For faster builds'
'mingw-w64-gcc: For compiling 64-bit Windows executables'
'valgrind: For tracing calls and profiling'
'wine: For running 64-bit Windows exectuables')
-source=("git+$url#commit=dcb95022c4deb4d70ca1ca4d9050eff535a54eb1") # tag: 3.2.8
-b2sums=('SKIP')
+source=("git+$url#commit=bac4780e070d7168a44e9f4ce596d27614eda02e") # tag: 3.3.0
+b2sums=(SKIP)
package() {
DESTDIR="$pkgdir" make -C $pkgname install