summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-09-01 16:01:30 +0200
committerAlexander F. Rødseth2019-09-01 16:01:30 +0200
commit6691a1e09bfdedf9e8901b24fdfd2b33eef93e69 (patch)
tree2af5d4fba53288be9ca7a2d0d175bfc765981a91
parentce8ad856c5ab8cf7b5f2c7e176e798efd3adf524 (diff)
downloadaur-6691a1e09bfdedf9e8901b24fdfd2b33eef93e69.tar.gz
Update to the latest version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4800cb818ce4..9fce09508e0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Aug 13 10:28:19 UTC 2019
pkgbase = cxx
pkgdesc = Build system for easy interaction with C++17 and C++20
- pkgver = 3.1.0
+ pkgver = 3.2.1
pkgrel = 1
url = https://github.com/xyproto/cxx
arch = x86_64
license = MIT
makedepends = git
depends = scons
+ optdepends = ccache: For faster builds
optdepends = lldb: For debugging
optdepends = clang: For clang-format and for clang++
optdepends = mingw-w64-gcc: For compiling 64-bit Windows executables
@@ -17,7 +16,7 @@ pkgbase = cxx
optdepends = gprof2dot: For visualizing profiling information
optdepends = graphviz: For visualizing profiling information
optdepends = kcachegrind: For visualizing profiling information
- source = git+https://github.com/xyproto/cxx#tag=3.1.0
+ source = git+https://github.com/xyproto/cxx#tag=3.2.1
sha256sums = SKIP
pkgname = cxx
diff --git a/PKGBUILD b/PKGBUILD
index d62ec2b439f3..356963c2582d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=cxx
-pkgver=3.1.0
+pkgver=3.2.1
pkgrel=1
pkgdesc='Build system for easy interaction with C++17 and C++20'
arch=(x86_64)
@@ -9,7 +9,8 @@ url='https://github.com/xyproto/cxx'
license=(MIT)
makedepends=(git)
depends=(scons)
-optdepends=('lldb: For debugging'
+optdepends=('ccache: For faster builds'
+ 'lldb: For debugging'
'clang: For clang-format and for clang++'
'mingw-w64-gcc: For compiling 64-bit Windows executables'
'wine: For running 64-bit Windows exectuables'
@@ -24,4 +25,5 @@ package() {
DESTDIR="$pkgdir" make -C $pkgname install
}
+# getver: github.com/xyproto/cxx/releases
# vim: ts=2 sw=2 et: