summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-12-26 22:09:30 +0100
committerAlexander F. Rødseth2018-12-26 22:09:30 +0100
commit770c07d1276fc88533e5de2e9e765029475f7e2e (patch)
tree009a45b090f9c61439ac515468e863a333393e65
downloadaur-770c07d1276fc88533e5de2e9e765029475f7e2e.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..daaefb16f33d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Dec 26 21:09:24 UTC 2018
+pkgbase = cxx
+ pkgdesc = Build system for executables written in C++17 or C++20
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = https://github.com/xyproto/cxx
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = scons
+ optdepends = lldb: For debugging
+ optdepends = clang: For clang-format and for clang++
+ optdepends = mingw-w64-gcc: For compiling 64-bit Windows executables
+ optdepends = wine: For running 64-bit Windows exectuables
+ optdepends = valgrind: For tracing calls and profiling
+ optdepends = gprof2dot: For visualizing profiling information
+ optdepends = graphviz: For visualizing profiling information
+ optdepends = kcachegrind: For visualizing profiling information
+ source = git+https://github.com/xyproto/cxx#tag=3.0.3
+ md5sums = SKIP
+
+pkgname = cxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..177f198deba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=cxx
+pkgver=3.0.3
+pkgrel=1
+pkgdesc='Build system for executables written in C++17 or C++20'
+arch=('x86_64')
+url='https://github.com/xyproto/cxx'
+license=('MIT')
+makedepends=('git')
+depends=('scons')
+optdepends=('lldb: For debugging'
+ 'clang: For clang-format and for clang++'
+ 'mingw-w64-gcc: For compiling 64-bit Windows executables'
+ 'wine: For running 64-bit Windows exectuables'
+ 'valgrind: For tracing calls and profiling'
+ 'gprof2dot: For visualizing profiling information'
+ 'graphviz: For visualizing profiling information'
+ 'kcachegrind: For visualizing profiling information')
+source=("git+https://github.com/xyproto/cxx#tag=$pkgver")
+md5sums=('SKIP')
+
+package() {
+ DESTDIR="$pkgdir" make -C "$pkgname" install
+}
+
+# vim: ts=2 sw=2 et: