summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-12-16 21:28:10 +0100
committerAlexander F. Rødseth2020-12-16 21:28:10 +0100
commitdc7df2dd783b53baaa9536893fa1a7cbcbf97c21 (patch)
treebdfda0245fc5c4454b8b80afc5ab5d0a13232ac9
parent6691a1e09bfdedf9e8901b24fdfd2b33eef93e69 (diff)
downloadaur-dc7df2dd783b53baaa9536893fa1a7cbcbf97c21.tar.gz
New release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fce09508e0e..17158a0e3508 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = cxx
- pkgdesc = Build system for easy interaction with C++17 and C++20
- pkgver = 3.2.1
+ pkgdesc = Configuration free build system for easy compilation of C++ executables
+ pkgver = 3.2.5
pkgrel = 1
url = https://github.com/xyproto/cxx
- arch = x86_64
+ arch = any
license = MIT
makedepends = git
depends = scons
@@ -16,7 +16,7 @@ pkgbase = cxx
optdepends = gprof2dot: For visualizing profiling information
optdepends = graphviz: For visualizing profiling information
optdepends = kcachegrind: For visualizing profiling information
- source = git+https://github.com/xyproto/cxx#tag=3.2.1
+ source = git+https://github.com/xyproto/cxx#commit=d6a59e8fae77c1ca9aa80e36ff62f75f6cbb901b
sha256sums = SKIP
pkgname = cxx
diff --git a/PKGBUILD b/PKGBUILD
index 356963c2582d..310a4d6c5562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=cxx
-pkgver=3.2.1
+pkgver=3.2.5
pkgrel=1
-pkgdesc='Build system for easy interaction with C++17 and C++20'
-arch=(x86_64)
+pkgdesc='Configuration free build system for easy compilation of C++ executables'
+arch=(any)
url='https://github.com/xyproto/cxx'
license=(MIT)
makedepends=(git)
@@ -18,7 +18,7 @@ optdepends=('ccache: For faster builds'
'gprof2dot: For visualizing profiling information'
'graphviz: For visualizing profiling information'
'kcachegrind: For visualizing profiling information')
-source=("git+$url#tag=$pkgver")
+source=("git+$url#commit=d6a59e8fae77c1ca9aa80e36ff62f75f6cbb901b") # tag: 3.2.5
sha256sums=('SKIP')
package() {
@@ -26,4 +26,3 @@ package() {
}
# getver: github.com/xyproto/cxx/releases
-# vim: ts=2 sw=2 et: