summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-11-13 20:21:11 -0600
committerkyechou2020-11-13 20:39:32 -0600
commit157337c95a6a3c432b2ab49a7ea5bfc87ed95948 (patch)
tree94cb64623c409a67084c88620a2d35c107d91223
downloadaur-157337c95a6a3c432b2ab49a7ea5bfc87ed95948.tar.gz
Initial commit: 0.0.14
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27fafee6676d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cxx-common
+ pkgdesc = Common dependency management for various Trail of Bits C++ codebases
+ pkgver = 0.0.14
+ pkgrel = 1
+ url = https://github.com/trailofbits/cxx-common
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = python
+ makedepends = llvm=11.0.0
+ makedepends = clang=11.0.0
+ makedepends = ninja
+ depends = openssl
+ depends = ncurses
+ depends = libxml2
+ depends = zlib
+ source = https://github.com/trailofbits/cxx-common/archive/v0.0.14.tar.gz
+ sha256sums = 1f7c3de3fa491cfba52abd4ae5fe5cc00112309239737b89ecc8c00a9b6cb2c2
+
+pkgname = cxx-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cca3efa664cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
+
+pkgname=cxx-common
+pkgver=0.0.14
+pkgrel=1
+pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
+arch=('x86_64')
+url="https://github.com/trailofbits/cxx-common"
+license=('Apache')
+depends=('openssl' 'ncurses' 'libxml2' 'zlib')
+makedepends=('cmake' 'python' 'llvm=11.0.0' 'clang=11.0.0' 'ninja')
+checkdepends=()
+source=("https://github.com/trailofbits/cxx-common/archive/v${pkgver}.tar.gz")
+sha256sums=('1f7c3de3fa491cfba52abd4ae5fe5cc00112309239737b89ecc8c00a9b6cb2c2')
+
+build() {
+ export TRAILOFBITS_LIBRARIES="$srcdir/libraries"
+ cd "$srcdir/$pkgname-$pkgver"
+ ./pkgman.py \
+ --llvm_version=1100 --c_compiler=clang --cxx_compiler=clang++ \
+ --repository_path="${TRAILOFBITS_LIBRARIES}" \
+ --packages=cmake,z3,llvm,google,xed,capnproto
+}
+
+package() {
+ install -dm 755 "$pkgdir/opt/$pkgname"
+ cp -r "$srcdir/libraries" "$pkgdir/opt/$pkgname/"
+ find "$pkgdir/opt/$pkgname/" -type f -exec sed -i -e "s|$srcdir|/opt/$pkgname|g" {} +
+}
+
+# vim: set sw=4 ts=4 et: