summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-09-26 20:53:56 +0200
committerbartus2017-09-26 20:53:56 +0200
commit13a58f55bad74578908d23709e9e6fe31a1b856a (patch)
tree2bca62b3f95365ceb4cc27f63760c5f3bc511ffb
downloadaur-13a58f55bad74578908d23709e9e6fe31a1b856a.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2a37bbac3fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cxxopts
+ pkgdesc = Lightweight C++ command line option parser
+ pkgver = 1.4.3.r0.g0b76869
+ pkgrel = 1
+ url = https://github.com/jarro2783/cxxopts
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ source = cxxopts::git+https://github.com/jarro2783/cxxopts.git
+ md5sums = SKIP
+
+pkgname = cxxopts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85405c18e50d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+pkgname=cxxopts
+#for fragment you can use one of: #commit=, #tag=, #branch=
+#fragment=
+pkgver=1.4.3.r0.g0b76869
+pkgrel=1
+pkgdesc="Lightweight C++ command line option parser"
+arch=(any)
+url="https://github.com/jarro2783/cxxopts"
+license=(MIT)
+makedepends=(git cmake)
+source=(${pkgname}::git+https://github.com/jarro2783/cxxopts.git${fragment})
+md5sums=(SKIP) #generate with 'makepkg -g'
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+package() {
+ cd ${pkgname}/build
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: