summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaron de Leeuw2013-10-03 19:15:19 +0300
committerYaron de Leeuw2013-10-03 19:15:19 +0300
commit09e3c42d1849d6ea037165a019dc99256ba31603 (patch)
tree9f721b43ea776b54e4becaf13bef74f32675f37f
downloadaur-09e3c42d1849d6ea037165a019dc99256ba31603.tar.gz
adopted cxxtools
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4174320450b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cxxtools
+ pkgdesc = A collection of general-purpose C++ classes
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://www.tntnet.org/cxxtools.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = gcc-libs
+ optdepends = bash: for running cxxtools-config
+ source = http://www.tntnet.org/download/cxxtools-2.2.tar.gz
+ md5sums = 9364b1221098c20f32fedf1338a56e56
+ sha512sums = d5eb004469b53e0d7eab3efefd756660094a2a6db2150b509f9e9442bd932657ad37d0cb06788c8944a3d9c4c897b3580e1b62e860cfbc30a8b4e912f22e69d3
+
+pkgname = cxxtools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720c04fc5177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yaron de Leeuw <jdlmail at gmail >
+# Contributor: Matz Radloff <matzradloff@gmx.de>
+# Contributor: Jan Willies <jan@willies.info>
+# Contributor: Carlos Franke <carlos_franke at lemtank dot de>
+
+pkgname="cxxtools"
+pkgver="2.2"
+pkgrel="1"
+pkgdesc="A collection of general-purpose C++ classes"
+url="http://www.tntnet.org/cxxtools.html"
+license=("LGPL")
+arch=("i686" "x86_64")
+source=(http://www.tntnet.org/download/$pkgname-$pkgver.tar.gz)
+depends=('gcc-libs')
+optdepends=(
+ 'bash: for running cxxtools-config'
+)
+md5sums=('9364b1221098c20f32fedf1338a56e56')
+sha512sums=('d5eb004469b53e0d7eab3efefd756660094a2a6db2150b509f9e9442bd932657ad37d0cb06788c8944a3d9c4c897b3580e1b62e860cfbc30a8b4e912f22e69d3')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}