summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Platte2015-07-22 21:21:10 +0200
committerJonas Platte2015-07-22 21:21:10 +0200
commitfd992a2a3d4e4bd499af9f5d73faeb02ab3bf0e0 (patch)
tree36d8d2c600babc43ff80c8cba881cc4da6095ebf
parent41fb96a8992c4ed8110e9aafcb3b5de815f3ac8e (diff)
downloadaur-fd992a2a3d4e4bd499af9f5d73faeb02ab3bf0e0.tar.gz
Upstream uses git tags now, fix pkgver()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29f0ee15781b..d3047160726d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cxxtools-git
pkgdesc = A collection of general-purpose C++ classes
- pkgver = 2.2.2.97e42ae
- pkgrel = 2
+ pkgver = V2.3rc1.r4.ge0ddfff
+ pkgrel = 1
url = http://www.tntnet.org/cxxtools.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 864dabdb66c6..0f239e2d664f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonas Platte <aur@jonasplatte.de>
pkgname=cxxtools-git
-pkgver=2.2.2.97e42ae
-pkgrel=2
+pkgver=V2.3rc1.r4.ge0ddfff
+pkgrel=1
pkgdesc="A collection of general-purpose C++ classes"
arch=('i686' 'x86_64')
url="http://www.tntnet.org/cxxtools.html"
@@ -14,11 +14,9 @@ conflicts=('cxxtools')
source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
sha256sums=('SKIP')
-# This will very likely break if cxxtools starts using tags. That is intentional,
-# as the --always will be removed then anyway, requiring an update
pkgver() {
cd "$pkgname"
- echo "2.2.2.$(git describe --always)"
+ git describe --long | sed 's/-/.r/;s/-/./'
}
build() {