summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-31 13:23:01 +0300
committerCaleb Maclennan2021-07-31 13:23:01 +0300
commit8107f33373560a467c09e0460ff4927acc18ae47 (patch)
tree71a05e2e020c2f3425b56f2a4dfd38d88649c5dc
downloadaur-8107f33373560a467c09e0460ff4927acc18ae47.tar.gz
Initial upload: cyan 0.1.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04bed7473995
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cyan
+ pkgdesc = The Teal build system and project manager
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/teal-language/cyan
+ arch = any
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ depends = lua-argparse
+ depends = lua-filesystem
+ depends = lua-tl
+ source = cyan-0.1.0.tar.gz::https://github.com/teal-language/cyan/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = d40cd2a130c9304d2534e3dc8b2f22a3f9d3d398e77ec2a788e22b5d50471984
+
+pkgname = cyan
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a77a892d3f39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=cyan
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="The Teal build system and project manager"
+arch=(any)
+url=https://github.com/teal-language/$pkgname
+license=(MIT)
+_lua_deps=(argparse
+ filesystem
+ tl)
+depends=(lua "${_lua_deps[@]/#/lua-}")
+makedepends=(luarocks)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('d40cd2a130c9304d2534e3dc8b2f22a3f9d3d398e77ec2a788e22b5d50471984')
+
+package() {
+ cd "$pkgname-$pkgver"
+ luarocks --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$pkgname-dev-1.rockspec"
+ find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
+}