summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZiqi Yang2023-12-21 20:00:56 +0800
committerZiqi Yang2023-12-21 20:00:56 +0800
commit97ba6853386827f81f85bb35bf93c62521cc65e1 (patch)
tree98e9424e8625270935419af8e95b2eb1cbe27955
downloadaur-97ba6853386827f81f85bb35bf93c62521cc65e1.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig11
-rw-r--r--.gitignore4
-rw-r--r--Makefile29
-rw-r--r--PKGBUILD33
-rw-r--r--changelog.txt12
6 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48f5805109d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cyber
+ pkgdesc = Fast and concurrent scripting.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/fubark/cyber
+ changelog = changelog.txt
+ arch = x86_64
+ license = MIT
+ makedepends = libarchive
+ provides = cyber
+ provides = cyberscript
+ conflicts = cyber
+ conflicts = cyberscript
+ source = https://github.com/fubark/cyber/releases/download/0.3/cyber-linux-x64.tar.gz
+ sha256sums = 0bd24ecee6ea20cfbc80d825cf8f9228fa837ce3aa141f7a4705190621b0a11b
+
+pkgname = cyber
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..c355e03f6a92
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,11 @@
+root = true
+
+[*]
+end_of_line = lf
+insert_final_newline = true
+charset = utf-8
+indent_style = space
+indent_size = 4
+
+[Makefile]
+indent_style = tab
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..38637c3a073d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.zst
+/*.proto
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..e8b1614a638a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,29 @@
+PKG_NAME := cyber-bin
+AUR_GIT_URL := ssh://aur@aur.archlinux.org/${PKG_NAME}.git
+
+.PHONY: all aur update build run
+all:
+ @echo commands:
+ @echo " " aur : Connect to AUR. Afterward you can run \'git push -u origin master\' to actually create a AUR repo.
+ @echo " " update : update checksum and SRCINFO
+ @echo " " build : forece build package
+ @echo " " install : install package on local machine
+
+aur:
+ git remote add origin ${AUR_GIT_URL}
+ git branch -m master # make sure the main branch is 'master' branch(currently AUR only accept this)
+ git fetch
+
+update: SHELL:=/bin/bash
+update:
+ makepkg --printsrcinfo > .SRCINFO # .SRCINFO must exists in all the commits
+# if there are at least one commit, delete those file not in git index ()
+# if you want to add files, manually add file to git using `git add`
+ @([[ $$(git ls-files) ]] && git clean -xdf ) || ( echo Please make your first stage or commit to ensure which files will not be deleted as cache files first && exit 1 )
+ env all_proxy=http://127.0.0.1:7890 updpkgsums # update package integrity checksum
+
+build: update
+ env all_proxy=http://127.0.0.1:7890 makepkg -sf
+
+install: update
+ env all_proxy=http://127.0.0.1:7890 makepkg -si --clean
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b727aeb6a724
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Meow King <mr.meowking@anche.no>
+pkgname=cyber
+pkgver=0.3 # NOTE
+pkgrel=1 # NOTE
+pkgdesc="Fast and concurrent scripting. "
+arch=("x86_64")
+url="https://github.com/fubark/cyber"
+license=('MIT')
+makedepends=(
+ "libarchive" # bsdtar
+)
+provides=("cyber" "cyberscript")
+conflicts=("cyber" "cyberscript")
+changelog="changelog.txt" # NOTE
+source=("${url}/releases/download/${pkgver}/cyber-linux-x64.tar.gz")
+sha256sums=('0bd24ecee6ea20cfbc80d825cf8f9228fa837ce3aa141f7a4705190621b0a11b')
+
+prepare() {
+ # bsdtar -xf data.tar.gz
+ echo 1
+}
+
+package() {
+ echo 1
+ # # bin
+ # install -Dm755 usr/bin/flying-carpet ${pkgdir}/usr/bin/flying-carpet
+ # # icons
+ # mkdir -p ${pkgdir}/usr/share/icons/
+ # chmod 755 ${pkgdir}/usr/share/icons
+ # cp -r usr/share/icons/hicolor ${pkgdir}/usr/share/icons/
+ # # desktop file
+ # install -Dm644 usr/share/applications/flying-carpet.desktop ${pkgdir}/usr/share/applications/flying-carpet.desktop
+}
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..68e491ba9b81
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,12 @@
+1. JIT compiler.
+2. Cycle dectector.
+3. Embed API.
+4. cbindgen.
+5. Type system.
+6. Operator overloading.
+7. Function overloading.
+8. Compiler rewrite.
+9. WASI target.
+10. Doc gen.
+
+More information: https://cyberscript.dev/0.3/index.html