summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Cabanilla2018-08-28 21:52:33 -0700
committerCarlo Cabanilla2018-08-28 21:52:33 -0700
commite3fac9fd970f132bbaa864c33e6cac05eaf47529 (patch)
tree6e5d4bf92dbb7f67921d8132689e40b96a79b5bf
downloadaur-e3fac9fd970f132bbaa864c33e6cac05eaf47529.tar.gz
v0.6.7
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69643aa7466a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Aug 29 04:52:17 UTC 2018
+pkgbase = cyberark-summon
+ pkgdesc = CLI that provides on-demand secrets access for common DevOps tools
+ pkgver = 0.6.7
+ pkgrel = 1
+ url = https://github.com/cyberark/summon
+ arch = x86_64
+ arch = i686
+ license = MIT
+ source = cyberark-summon-0.6.7.tar.gz::https://github.com/cyberark/summon/releases/download/v0.6.7/summon-linux-amd64.tar.gz
+ sha256sums = 60bc2ee872e00a54f97d4e390d5f076d70b639cf3574ad2bcbb9bf3f6af67227
+
+pkgname = cyberark-summon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..703cbea26e1c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf79af888e2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Carlo Cabanilla <carlo.cabanilla@gmail.com>
+
+pkgname=cyberark-summon
+pkgver=0.6.7
+pkgrel=1
+pkgdesc='CLI that provides on-demand secrets access for common DevOps tools'
+arch=('x86_64' 'i686')
+url='https://github.com/cyberark/summon'
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/cyberark/summon/releases/download/v${pkgver}/summon-linux-amd64.tar.gz")
+sha256sums=('60bc2ee872e00a54f97d4e390d5f076d70b639cf3574ad2bcbb9bf3f6af67227')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin/"
+ tar -xzf $pkgname-$pkgver.tar.gz -C "${pkgdir}/usr/bin/"
+ mv "${pkgdir}/usr/bin/summon" "${pkgdir}/usr/bin/cyberark-summon"
+ chmod 0755 "${pkgdir}/usr/bin/cyberark-summon"
+}