summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-03-03 20:02:28 +0100
committerCarl Smedstad2023-03-03 20:08:53 +0100
commit24e6f16fc21ce6e1b0e86e611e872f434024fd67 (patch)
tree59d7a0b0eac8cfadab3cad21165cf693583e7a99
parent59899342ade1c3c7ce68724f276f979b0e9caaa2 (diff)
downloadaur-24e6f16fc21ce6e1b0e86e611e872f434024fd67.tar.gz
Take over maintenance & publish version 1.4.1
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
-rw-r--r--cyberghostvpn.install13
4 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6d7c74ae0aa..3a8f8d6e2917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cyberghostvpn
pkgdesc = CyberGhost VPN
- pkgver = 1.3.4
- pkgrel = 4
+ pkgver = 1.4.1
+ pkgrel = 1
url = https://www.cyberghostvpn.com
install = cyberghostvpn.install
arch = any
@@ -11,8 +11,7 @@ pkgbase = cyberghostvpn
depends = openvpn
depends = wireguard-tools
depends = systemd-resolvconf
- source = https://download.cyberghostvpn.com/linux/cyberghostvpn-ubuntu-20.04-1.3.4.zip
- sha256sums = fe9635b244231f943e8f05118e194a696b1e318fee265f06d138a08a421fb07f
+ source = https://download.cyberghostvpn.com/linux/cyberghostvpn-ubuntu-20.04-1.4.1.zip
+ sha256sums = 355ab80f3445968161f6db9565857a9af8df61fd6292b4c4267579ff128f3007
pkgname = cyberghostvpn
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3fc66926f9bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!cyberghostvpn.install
diff --git a/PKGBUILD b/PKGBUILD
index 4e255c5f3a38..60d8525c6bd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Hojjat Ali Mohammadi <safeith@gmail.com>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Hojjat Ali Mohammadi <safeith@gmail.com>
+
pkgname=cyberghostvpn
-pkgver=1.3.4
-pkgrel=4
+pkgver=1.4.1
+pkgrel=1
pkgdesc="CyberGhost VPN"
url="https://www.cyberghostvpn.com"
-arch=('any')
-license=('custom:cyberghostvpn')
-depends=('curl' 'openvpn' 'wireguard-tools' 'systemd-resolvconf')
-makedepends=('zip')
+arch=(any)
+license=(custom:cyberghostvpn)
+depends=(
+ curl
+ openvpn
+ wireguard-tools
+ systemd-resolvconf
+)
+makedepends=(zip)
install="${pkgname}.install"
-source=("https://download.cyberghostvpn.com/linux/${pkgname}-ubuntu-20.04-${pkgver}.zip")
-sha256sums=('fe9635b244231f943e8f05118e194a696b1e318fee265f06d138a08a421fb07f')
+
+source=("https://download.cyberghostvpn.com/linux/cyberghostvpn-ubuntu-20.04-${pkgver}.zip")
+sha256sums=('355ab80f3445968161f6db9565857a9af8df61fd6292b4c4267579ff128f3007')
package() {
- mkdir -p "$pkgdir/usr/local/cyberghost"
- install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}/cyberghost/cyberghostvpn" "$pkgdir/usr/local/cyberghost/"
- install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}/cyberghost/update-systemd-resolved" "$pkgdir/usr/local/cyberghost/"
+ mkdir -p "$pkgdir/opt/cyberghost"
+
+ install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}/cyberghost/cyberghostvpn" "$pkgdir/opt/cyberghost/"
+ install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}/cyberghost/update-systemd-resolved" "$pkgdir/opt/cyberghost/"
}
diff --git a/cyberghostvpn.install b/cyberghostvpn.install
index 82072e87cbbf..4279604432ff 100644
--- a/cyberghostvpn.install
+++ b/cyberghostvpn.install
@@ -4,20 +4,19 @@ blue="${bold}$(tput setaf 4)"
yellow="${bold}$(tput setaf 3)"
note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+ printf "%s==>%s NOTE:%s %s%s\n" "${blue}" "${yellow}" "${bold}" "$1" "${all_off}"
}
post_install() {
- ln -sf /usr/local/cyberghost/cyberghostvpn /usr/bin/cyberghostvpn
- note "Enable systemd-resolved: systemctl enable systemd-resolved.service"
- note "Setup your account: cyberghostvpn --setup"
+ ln -sf /opt/cyberghost/cyberghostvpn /usr/bin/cyberghostvpn
+ note "Enable systemd-resolved: systemctl enable systemd-resolved.service"
+ note "Setup your account: cyberghostvpn --setup"
}
post_upgrade() {
- post_install
+ post_install
}
post_remove() {
- unlink /usr/bin/cyberghostvpn
- rm -rf /usr/local/cyberghost
+ unlink /usr/bin/cyberghostvpn
}