summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHojjat Ali Mohammadi2021-02-18 21:46:17 +0100
committerHojjat Ali Mohammadi2021-02-18 21:46:17 +0100
commit2b0a3ad16602ffdb06bce7e2606a993c873e239b (patch)
tree689af7404542fe89b499bbed8264debe7deaf095
downloadaur-2b0a3ad16602ffdb06bce7e2606a993c873e239b.tar.gz
Publish CyberGhost VPN
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
-rw-r--r--cyberghostvpn.install21
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d83ca995f063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cyberghostvpn
+ pkgdesc = CyberGhost VPN
+ pkgver = 1.3
+ pkgrel = 4
+ url = https://www.cyberghostvpn.com
+ install = cyberghostvpn.install
+ arch = any
+ license = custom:cyberghostvpn
+ makedepends = zip
+ depends = curl
+ depends = openvpn
+ depends = wireguard-tools
+ depends = systemd-resolvconf
+ source = https://download.cyberghostvpn.com/linux/cyberghostvpn-ubuntu-20.04-1.3.4.zip
+ sha256sums = d28d6008c71896bdb3af67d4d047eb4738e061e7cd5d2d9debef7e90b875fec5
+
+pkgname = cyberghostvpn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff1afa1dca23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Hojjat Ali Mohammadi <safeith@gmail.com>
+pkgname=cyberghostvpn
+pkgver=1.3
+pkgrel=4
+pkgdesc="CyberGhost VPN"
+url="https://www.cyberghostvpn.com"
+arch=('any')
+license=('custom:cyberghostvpn')
+depends=('curl' 'openvpn' 'wireguard-tools' 'systemd-resolvconf')
+makedepends=('zip')
+install="${pkgname}.install"
+source=("https://download.cyberghostvpn.com/linux/${pkgname}-ubuntu-20.04-${pkgver}.${pkgrel}.zip")
+sha256sums=('d28d6008c71896bdb3af67d4d047eb4738e061e7cd5d2d9debef7e90b875fec5')
+
+package() {
+ mkdir -p "$pkgdir/usr/local/cyberghost"
+ install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}.${pkgrel}/cyberghost/cyberghostvpn" "$pkgdir/usr/local/cyberghost/"
+ install -m 755 "$srcdir/${pkgname}-ubuntu-20.04-${pkgver}.${pkgrel}/cyberghost/update-systemd-resolved" "$pkgdir/usr/local/cyberghost/"
+}
diff --git a/cyberghostvpn.install b/cyberghostvpn.install
new file mode 100644
index 000000000000..10acd806a02b
--- /dev/null
+++ b/cyberghostvpn.install
@@ -0,0 +1,21 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+post_install() {
+ note "Enable systemd-resolved: systemctl enable systemd-resolved.service"
+ note "Setup your account: cyberghostvpn --setup"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm -rf /usr/local/cyberghost
+}