summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel L2021-12-02 23:59:07 +0100
committerDaniel L2021-12-03 00:00:58 +0100
commitbe39ad7a3c265ea83d5f115ab656b44817e1b131 (patch)
tree3cb5f82f17b69ed38f2b9a3703125a3e351cea2d
downloadaur-be39ad7a3c265ea83d5f115ab656b44817e1b131.tar.gz
Initial commit
This package is a variation of cyberghostvpn because users with NetworkManager may experience issues with systemd-resolv and cyberghostvpn
-rwxr-xr-x.SRCINFO19
-rwxr-xr-xPKGBUILD21
-rwxr-xr-xcyberghostvpn.install22
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..150b3f141d4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cyberghostvpn-openresolv
+ pkgdesc = CyberGhost VPN (with openresolv for clients using NetworkManager)
+ pkgver = 1.3.4
+ pkgrel = 3
+ url = https://www.cyberghostvpn.com
+ install = cyberghostvpn.install
+ arch = any
+ license = custom:cyberghostvpn
+ makedepends = zip
+ depends = curl
+ depends = openvpn
+ depends = wireguard-tools
+ depends = openresolv
+ conflicts = cyberghostvpn
+ source = https://download.cyberghostvpn.com/linux/cyberghostvpn-ubuntu-20.04-1.3.4.zip
+ sha256sums = d28d6008c71896bdb3af67d4d047eb4738e061e7cd5d2d9debef7e90b875fec5
+
+pkgname = cyberghostvpn-openresolv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e60412efb4c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel Lehmann <daniellehmann28@outlook.de>
+pkgname=cyberghostvpn-openresolv
+_pkgname=cyberghostvpn
+pkgver=1.3.4
+pkgrel=3
+pkgdesc="CyberGhost VPN"
+url="https://www.cyberghostvpn.com"
+arch=('any')
+license=('custom:cyberghostvpn')
+depends=('curl' 'openvpn' 'wireguard-tools' 'openresolv')
+conflicts=('cyberghostvpn')
+makedepends=('zip')
+install="${_pkgname}.install"
+source=("https://download.cyberghostvpn.com/linux/${_pkgname}-ubuntu-20.04-${pkgver}.zip")
+sha256sums=('d28d6008c71896bdb3af67d4d047eb4738e061e7cd5d2d9debef7e90b875fec5')
+
+package() {
+ mkdir -p "$pkgdir/usr/local/cyberghost"
+ install -m 755 "$srcdir/${_pkgname}-ubuntu-20.04-${pkgver}/cyberghost/cyberghostvpn" "$pkgdir/usr/local/cyberghost/"
+ install -m 755 "$srcdir/${_pkgname}-ubuntu-20.04-${pkgver}/cyberghost/update-systemd-resolved" "$pkgdir/usr/local/cyberghost/"
+}
diff --git a/cyberghostvpn.install b/cyberghostvpn.install
new file mode 100755
index 000000000000..1a9e30e39772
--- /dev/null
+++ b/cyberghostvpn.install
@@ -0,0 +1,22 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+post_install() {
+ ln -sf /usr/local/cyberghost/cyberghostvpn /usr/bin/cyberghostvpn
+ note "Setup your account: cyberghostvpn --setup"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ unlink /usr/bin/cyberghostvpn
+ rm -rf /usr/local/cyberghost
+}