summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Ethier2016-07-21 17:31:42 -0400
committerJustin Ethier2016-07-21 17:31:42 -0400
commit21507d1e0772913c41dc42766d43e90c23bc967a (patch)
treeddfc9d210b8824c01d294848abbaffb1d953c8a3
downloadaur-21507d1e0772913c41dc42766d43e90c23bc967a.tar.gz
Initial files for Cyclone 0.1.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f38fb9319aae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cyclone-scheme
+ pkgdesc = An R7RS Scheme-to-C compiler using Cheney on the M.T.A with native threads
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/justinethier/cyclone-bootstrap
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libck
+ source = https://github.com/justinethier/cyclone-bootstrap/archive/v0.1.4.tar.gz
+ md5sums = 3e30f357927d2de24c6dd8f2b0c34646
+
+pkgname = cyclone-scheme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f84ed15f500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Justin Ethier <justin.ethier@gmail.com>
+pkgname=cyclone-scheme
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="An R7RS Scheme-to-C compiler using Cheney on the M.T.A with native threads"
+arch=('i686' 'x86_64')
+url="https://github.com/justinethier/cyclone-bootstrap"
+license=('MIT')
+groups=()
+depends=('libck')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($url/archive/v$pkgver.tar.gz)
+noextract=()
+#autofill using updpkgsums
+md5sums=('3e30f357927d2de24c6dd8f2b0c34646')
+
+build() {
+ cd "cyclone-bootstrap-$pkgver"
+ make libcyclone.a PREFIX=/usr
+ make cyclone CFLAGS="-g -L. -Iinclude" PREFIX=/usr
+ make icyc-c CFLAGS="-g -L. -Iinclude" PREFIX=/usr
+}
+
+package() {
+ cd "cyclone-bootstrap-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX=/usr install-deps
+ make DESTDIR="$pkgdir" PREFIX=/usr install-libs
+ make DESTDIR="$pkgdir" PREFIX=/usr install-cyclone
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}