diff options
author | Justin Ethier | 2017-04-23 17:18:35 -0400 |
---|---|---|
committer | Justin Ethier | 2017-04-23 17:18:35 -0400 |
commit | b9faceac0a5aa020b4cb0bc81434b08ed617e954 (patch) | |
tree | b8000358200c9c91bba5bb66028acd0163bb58a2 | |
parent | d916a6c6d3493b262229ceff882a7bb564e0a440 (diff) | |
download | aur-b9faceac0a5aa020b4cb0bc81434b08ed617e954.tar.gz |
Add proper CFLAGS for v0.5
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 10 |
2 files changed, 6 insertions, 6 deletions
@@ -1,7 +1,7 @@ pkgbase = cyclone-scheme pkgdesc = A brand-new compiler that allows practical application development using R7RS Scheme pkgver = 0.5 - pkgrel = 1 + pkgrel = 2 url = https://github.com/justinethier/cyclone-bootstrap arch = i686 arch = x86_64 @@ -1,7 +1,7 @@ # Maintainer: Justin Ethier <justin.ethier@gmail.com> pkgname=cyclone-scheme pkgver=0.5 -pkgrel=1 +pkgrel=2 pkgdesc="A brand-new compiler that allows practical application development using R7RS Scheme" arch=('i686' 'x86_64') url="https://github.com/justinethier/cyclone-bootstrap" @@ -24,13 +24,13 @@ md5sums=('061930a8b2e2484640f7412425691447') build() { cd "cyclone-bootstrap-$pkgver" - make libcyclone.a PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L." - make cyclone PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L." - make icyc-c PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L." + make libcyclone.a PREFIX=/usr CFLAGS="-O2 -fPIC -rdynamic -Wall -Iinclude -L." + make cyclone PREFIX=/usr CFLAGS="-O2 -fPIC -rdynamic -Wall -Iinclude -L." + make icyc-c PREFIX=/usr CFLAGS="-O2 -fPIC -rdynamic -Wall -Iinclude -L." } package() { cd "cyclone-bootstrap-$pkgver" - make DESTDIR="$pkgdir" PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L." + make DESTDIR="$pkgdir" PREFIX=/usr CFLAGS="-O2 -fPIC -rdynamic -Wall -Iinclude -L." make DESTDIR="$pkgdir" PREFIX=/usr install } |