summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Ethier2016-10-23 18:37:24 +0000
committerJustin Ethier2016-10-23 18:37:24 +0000
commitc21f4a199455d299ce7e16e194264f6a46bae8df (patch)
tree37cd2c7bf2726afb06cedc48d35b62e0763a61b0
parentf37da67f65528f955e00dab5cd61d8e3eca45d25 (diff)
downloadaur-c21f4a199455d299ce7e16e194264f6a46bae8df.tar.gz
New pkgrel
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52a8cbdbc8b1..d453c7672caf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cyclone-scheme
pkgdesc = An R7RS Scheme-to-C compiler using Cheney on the M.T.A with native threads
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/justinethier/cyclone-bootstrap
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 01b9f8967f0a..c3e804eff265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Justin Ethier <justin.ethier@gmail.com>
pkgname=cyclone-scheme
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="An R7RS Scheme-to-C compiler using Cheney on the M.T.A with native threads"
arch=('i686' 'x86_64')
url="https://github.com/justinethier/cyclone-bootstrap"
@@ -24,13 +24,13 @@ md5sums=('89c5b3d5ac379a32acb166296d71e750')
build() {
cd "cyclone-bootstrap-$pkgver"
- make libcyclone.a PREFIX=/usr
- make cyclone CFLAGS="-g -L. -Iinclude" PREFIX=/usr
- make icyc-c CFLAGS="-g -L. -Iinclude" PREFIX=/usr
+ make libcyclone.a PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L."
+ make cyclone PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L."
+ make icyc-c PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L."
}
package() {
cd "cyclone-bootstrap-$pkgver"
- make DESTDIR="$pkgdir" PREFIX=/usr
+ make DESTDIR="$pkgdir" PREFIX=/usr CFLAGS="-O2 -Wall -Iinclude -L."
make DESTDIR="$pkgdir" PREFIX=/usr install
}