summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblooser2019-01-10 11:31:03 +0100
committerblooser2019-01-10 11:31:03 +0100
commit479a58ab6a2475a8a823a9a85207b669a155a6c5 (patch)
tree2a49a5946c9b9ec8f1d2fb6eec876386e1363011
downloadaur-479a58ab6a2475a8a823a9a85207b669a155a6c5.tar.gz
Initialize
Signed-off-by: blooser <Blooser@protonmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c915acfb478a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cygnus
+ pkgdesc = RSS reader
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/blooser/cygnus
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python3
+ source = https://github.com/blooser/cygnus/archive/v1.3.tar.gz
+ md5sums = 26cfda2c5b20496debe039d94207404d
+
+pkgname = cygnus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b434e4e98c8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Blooser <blooser@protonmail.com>
+pkgname=cygnus
+pkgver=1.3
+pkgrel=1
+pkgdesc="RSS reader"
+arch=('x86_64')
+md5sums=('26cfda2c5b20496debe039d94207404d')
+url="https://github.com/blooser/cygnus"
+license=('MIT')
+depends=('python3')
+makedepends=('python-setuptools')
+applocation=~/Documents/$pkgname
+shortcut="
+[Desktop Entry]
+Encoding=UTF-8
+Version=${pkgver}
+Name[en_US]=Cygnus
+GenericName=RSS reader
+Exec=${applocation}/run.sh
+Icon[en_US]=${applocation}/icons/rss.png
+Type=Application
+Categories=Application;Network
+Comment[en_US]=Be always up to date
+"
+
+runscript="
+cd ${applocation}
+python3 main.py
+"
+
+source=("https://github.com/blooser/cygnus/archive/v${pkgver}.tar.gz")
+
+build() {
+ sudo pip install PyQt5 pygame feedparser pillow
+}
+
+package() {
+ echo "${runscript}" > $pkgname-$pkgver/run.sh
+ chmod +x $pkgname-$pkgver/run.sh
+ cp -r $pkgname-$pkgver $applocation
+ rm -rf $pkgname-$pkgver
+ echo "${shortcut}" > ~/.local/share/applications/cygnus.desktop
+ if [ -f ~/.zshrc ]; then
+ echo "alias cygnus=${applocation}/run.sh" >> ~/.zshrc
+ else
+ echo "alias cygnus=${applocation}/run.sh" >> ~/.bashrc
+ fi
+}