summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin lyons2016-10-09 19:23:28 +0100
committerGavin lyons2016-10-09 19:23:28 +0100
commit1f2549c0888ad8741c3b7af97e1eff0095fd40cb (patch)
treeba6fe7fd7c6b12935e34d03e8ad8e8b7b330db50
parent8a460e372e50e5529b8c92eb94a478da7b5e6e5d (diff)
downloadaur-1f2549c0888ad8741c3b7af97e1eff0095fd40cb.tar.gz
version 2.2-1 see changelog.md for details
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 121aa5ef96d1..747c7fe45a31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cylon
- pkgdesc = Maintenance , backup and system checks in a menu driven Bash script
- pkgver = 2.1
- pkgrel = 9
+ pkgdesc = Updates, Maintenance, backup and system checks in a menu driven Bash script
+ pkgver = 2.2
+ pkgrel = 1
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
@@ -13,8 +13,9 @@ pkgbase = cylon
optdepends = clamav: used for finding malware
optdepends = bleachbit: used for system clean
optdepends = gnu-netcat: used for checking network
- source = https://github.com/gavinlyonsrepo/cylon/archive/2.1.tar.gz
- md5sums = 7e6973306b95e8d91a45b64253ac55cd
+ optdepends = ccrypt: used for encrypting
+ source = https://github.com/gavinlyonsrepo/cylon/archive/2.2.tar.gz
+ md5sums = dc164e42ad8cc49008f3c0d705dc676a
pkgname = cylon
diff --git a/PKGBUILD b/PKGBUILD
index c06e908c5065..453ac97f5c9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=2.1
-pkgrel=9
-pkgdesc="Maintenance , backup and system checks in a menu driven Bash script"
+pkgver=2.2
+pkgrel=1
+pkgdesc="Updates, Maintenance, backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
license=('GPL')
@@ -16,14 +16,15 @@ optdepends=(
'clamav: used for finding malware'
'bleachbit: used for system clean'
'gnu-netcat: used for checking network'
+ 'ccrypt: used for encrypting'
)
-#source=("git://github.com/gavinlyonsrepo/${pkgname}.git")
source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
-md5sums=('7e6973306b95e8d91a45b64253ac55cd')
+md5sums=('dc164e42ad8cc49008f3c0d705dc676a')
package() {
cd "$srcdir/${pkgname}-${pkgver}"
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname}"
- install -D -m644 Readme.md "$HOME"/.config/cylon/cylonReadme.md
+ install -D -m644 Readme.md "$pkgdir/usr/share/doc/${pkgname}/Readme.md"
+ install -D -m644 changelog.md "$pkgdir/usr/share/doc/${pkgname}/changelog.md"
install -D -m644 License.md "$pkgdir/usr/share/licenses/${pkgname}/License.md"
}