summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin lyons2016-12-26 15:44:44 +0000
committerGavin lyons2016-12-26 15:44:44 +0000
commit4be7f81a660a59cda3a77a8073e33f37216f051c (patch)
tree7143fe104d752c48f2d44404d2c9cf479af0b09f
parent23b3203124d24aa2aa9cfa52b1b7f3007dbd44d4 (diff)
downloadaur-4be7f81a660a59cda3a77a8073e33f37216f051c.tar.gz
Version 3.2-3 see changelog.md for details
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42a6f9e34f0c..f0e856b91942 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cylon
pkgdesc = Updates, Maintenance, backup and system checks in a menu driven Bash script
- pkgver = 3.1
- pkgrel = 2
+ pkgver = 3.2
+ pkgrel = 3
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
@@ -23,8 +23,8 @@ pkgbase = cylon
optdepends = speedtest-cli: internet bandwidth
optdepends = lynis: system audit tool
optdepends = openbsd-netcat: used for checking network
- source = https://github.com/gavinlyonsrepo/cylon/archive/3.1.tar.gz
- md5sums = c41fb7841fa5c03601f2aa7b8a551d5f
+ source = https://github.com/gavinlyonsrepo/cylon/archive/3.2.tar.gz
+ md5sums = 76d4a28cda5d27256d1a7a6a00cb3e2c
pkgname = cylon
diff --git a/PKGBUILD b/PKGBUILD
index 06460b0eb8af..1da0f2806998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=3.1
-pkgrel=2
+pkgver=3.2
+pkgrel=3
pkgdesc="Updates, Maintenance, backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
@@ -28,12 +28,17 @@ optdepends=(
'openbsd-netcat: used for checking network'
)
source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
-md5sums=('c41fb7841fa5c03601f2aa7b8a551d5f')
+md5sums=('76d4a28cda5d27256d1a7a6a00cb3e2c')
package() {
cd "$srcdir/${pkgname}-${pkgver}"
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname}"
install -D -m644 Readme.md "$pkgdir/usr/share/doc/${pkgname}/Readme.md"
+ install -D -m644 cylon.7 "$pkgdir/usr/share/man/man7/cylon.7"
install -D -m644 changelog.md "$pkgdir/usr/share/doc/${pkgname}/changelog.md"
install -D -m644 License.md "$pkgdir/usr/share/licenses/${pkgname}/License.md"
+ install -D -m644 cylon.desktop "$pkgdir/usr/share/applications/cylon.desktop"
+ install -D -m644 cylonicon.png "$pkgdir/usr/share/pixmaps/cylonicon.png"
+ install -d "$pkgdir"/usr/lib/cylon/modules
+ install -D -m644 modules/*_module "$pkgdir"/usr/lib/cylon/modules
}