summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-22 19:09:52 -0400
committertheunpleasantowl2018-08-22 19:09:52 -0400
commit909315ce1054e2dda05b8a802010d99c01e42795 (patch)
tree0b4f9a5f163494e2e38eb4f64f80bb7967a04842
parentc26e68599a2d43c1268b0671ddd9d3b006a6fd9c (diff)
downloadaur-909315ce1054e2dda05b8a802010d99c01e42795.tar.gz
enable opt deps
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f25f033f8b0b..54118703e780 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,12 +12,12 @@ pkgbase = cynthiune.app
depends = gnustep-base
depends = gnustep-gui
depends = gnustep-back
- depends = libid3tag
- depends = libmad
- depends = libvorbis
- depends = libogg
- depends = libmpcdec
- depends = esound
+ optdepends = libid3tag
+ optdepends = libmad
+ optdepends = libvorbis
+ optdepends = libogg
+ optdepends = libmpcdec
+ optdepends = esound
source = http://savannah.nongnu.org/download/gap/Cynthiune-1.0.0.tar.gz
sha256sums = 3cc5228c8cdb66256bbcec4b317bbd3853397f09ec9b7378a7f65140eff5bcaf
diff --git a/PKGBUILD b/PKGBUILD
index 234f51cb1b7d..a72ea20875a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,20 +9,30 @@ arch=('i686' 'x86_64')
url='http://gap.nongnu.org/cynthiune/index.html'
license=('GPL')
groups=('gnustep-apps')
-depends=('gnustep-base' 'gnustep-gui' 'gnustep-back' 'libid3tag' 'libmad' 'libvorbis' 'libogg' 'libmpcdec' 'esound')
-#optdepends=('libid3tag' 'libmad' 'libvorbis' 'libogg' 'libmpcdec' 'esound')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+optdepends=('libid3tag' 'libmad' 'libvorbis' 'libogg' 'libmpcdec' 'esound')
makedepends=('gcc-objc' 'gnustep-make')
source=("http://savannah.nongnu.org/download/gap/Cynthiune-1.0.0.tar.gz")
sha256sums=('3cc5228c8cdb66256bbcec4b317bbd3853397f09ec9b7378a7f65140eff5bcaf')
-build() {
+prepare() {
cd $_pkgname-$pkgver
-
# Leave out avifile library until available
if test "$pkg-config --exists avifile" != 0; then
sed -i '70,73{s/^.*//}' GNUmakefile
fi
+ #libmpcdec
+ if test "$pkg-config --exists esound" != 0; then
+ sed -i '74,76{s/^.*//}' GNUmakefile
+ fi
+ #esound
+ if test "$pkg-config --exists esound" != 0; then
+ sed -i '118,120{s/^.*//}' GNUmakefile
+ fi
+}
+build() {
+ cd $_pkgname-$pkgver
export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}