summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Melling2018-07-29 20:37:52 +0100
committerMatt Melling2018-07-29 20:37:52 +0100
commit22eab087f0cd2a209d8b5c90cc8801622edfd590 (patch)
tree793b1aa8dcaa1fadb874976922dc7e13d93fc834
downloadaur-22eab087f0cd2a209d8b5c90cc8801622edfd590.tar.gz
first version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfe318aafd44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cypher-shell-git
+ pkgdesc = A command line shell where you can execute Cypher against an instance of Neo4j (install from git)
+ pkgver = neo4j.3.4.5.r7.g31a7bef
+ pkgrel = 1
+ url = https://github.com/neo4j/cypher-shell
+ arch = any
+ license = GPL
+ makedepends = jdk8-openjdk
+ makedepends = maven
+ depends = java-environment=8
+ depends = bash
+ conflicts = cypher-shell
+ options = !strip
+ source = cypher-shell-git::git+https://github.com/neo4j/cypher-shell.git
+ sha256sums = SKIP
+
+pkgname = cypher-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f44874a0ca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Matt Melling <mattmelling@fastmail.com>
+
+pkgname=cypher-shell-git
+pkgdesc="A command line shell where you can execute Cypher against an instance of Neo4j (install from git)"
+pkgver=neo4j.3.4.5.r7.g31a7bef
+pkgrel=1
+arch=("any")
+url="https://github.com/neo4j/cypher-shell"
+license=("GPL")
+makedepends=("jdk8-openjdk" "maven")
+depends=("java-environment=8" "bash")
+options=(!strip)
+source=("$pkgname::git+https://github.com/neo4j/cypher-shell.git")
+sha256sums=("SKIP")
+conflicts=("cypher-shell")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make build
+}
+
+package() {
+ installdir="${srcdir}/${pkgname}/cypher-shell/build/install/cypher-shell/"
+ install -D -m644 "${installdir}/cypher-shell-all.jar" "${pkgdir}/usr/share/cypher-shell/lib/cypher-shell-all.jar"
+ install -D -m755 "${installdir}/cypher-shell" "${pkgdir}/usr/bin/cypher-shell"
+}