summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2016-11-10 01:44:32 +0100
committerDaniel Maslowski2016-11-10 01:44:32 +0100
commit2827bc872ace37524e690ea2e80903ea99d79d63 (patch)
tree39c157eeb4af7c8f5e93eeb4616aab25c5557ebe
downloadaur-2827bc872ace37524e690ea2e80903ea99d79d63.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
-rw-r--r--cypress.desktop13
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee454d2bdf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Nov 10 00:44:28 UTC 2016
+pkgbase = cypress
+ pkgdesc = test engine that runs unit and integration tests in your browser
+ pkgver = 0.17.10
+ pkgrel = 1
+ url = http://www.cypress.io
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ depends = xorg-server-xvfb
+ depends = lib32-gtk2
+ depends = lib32-gconf>=2.4
+ depends = lib32-nss
+ depends = libnotify
+ optdepends = nodejs-cypress-cli: for headless mode
+ source = cypress.zip::https://download.cypress.io/desktop/0.17.10?os=linux64
+ source = cypress.desktop
+ sha512sums = 4281702f626caba2d70953e2cc3967526365bc125cd31cdcf1c8394a0d50aa16e37c7037f6ad528e6611a3134c4f82d8944b99868453f363a07f8b3257d2076b
+ sha512sums = 1b48157cf3ddd21ca58e2cd3df7998c01966a02a544fdfc7c5eedf5aee8757c541d5dc9df64fcdee65256a29141fa491c638bf9cd98b4e9df5030ec98ebc4251
+
+pkgname = cypress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69635ce0019b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+
+pkgname=cypress
+pkgver=0.17.10
+pkgrel=1
+pkgdesc='test engine that runs unit and integration tests in your browser'
+arch=('x86_64')
+url='http://www.cypress.io'
+license=('MIT')
+depends=('xorg-server-xvfb' 'lib32-gtk2' 'lib32-gconf>=2.4' 'lib32-nss' 'libnotify')
+makedepends=('unzip')
+optdepends=('nodejs-cypress-cli: for headless mode')
+source=(
+ "cypress.zip::https://download.cypress.io/desktop/$pkgver?os=linux64"
+ 'cypress.desktop'
+)
+sha512sums=('4281702f626caba2d70953e2cc3967526365bc125cd31cdcf1c8394a0d50aa16e37c7037f6ad528e6611a3134c4f82d8944b99868453f363a07f8b3257d2076b'
+ '1b48157cf3ddd21ca58e2cd3df7998c01966a02a544fdfc7c5eedf5aee8757c541d5dc9df64fcdee65256a29141fa491c638bf9cd98b4e9df5030ec98ebc4251')
+
+package() {
+ mkdir "$pkgdir/opt"
+ cp -a "$srcdir/Cypress" "$pkgdir/opt/Cypress"
+ chmod 666 "$pkgdir/opt/Cypress/resources/app/node_modules/@cypress/core-extension/dist/background.js"
+ install -Dm 644 cypress.desktop "$pkgdir/usr/share/applications/cypress.desktop"
+ install -Dm 644 "$srcdir/Cypress/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 "$srcdir/Cypress/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+}
diff --git a/cypress.desktop b/cypress.desktop
new file mode 100644
index 000000000000..867be8b674a2
--- /dev/null
+++ b/cypress.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Cypress
+Comment=Cypress.io Desktop App
+GenericName=Cypress
+Exec=/opt/Cypress/Cypress %U
+Icon=/opt/Cypress/resources/app/lib/public/img/icon_128x128@2x.png
+Terminal=false
+Type=Application
+StartupNotify=true
+StartupWMClass=cypress
+Keywords=Cypress;Testing;
+Categories=Development;
+X-GNOME-UsesNotifications=false