summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-12-27 01:33:50 +0800
committerChocobo12022-12-27 02:06:08 +0800
commit9b930a91b26f782cf8bcf0f896abca38eb5ae404 (patch)
treeedd0768d2b854b331c8ca03c31bb4f796375dd2f
parent0ceb4c7c62be150d92125e1fc0dcf220e1f72656 (diff)
downloadaur-9b930a91b26f782cf8bcf0f896abca38eb5ae404.tar.gz
upgpkg: cython-git 3.0.0a11.r191.g8fcc9896f-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35749b54e951..f07414062c52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = cython-git
pkgdesc = C-Extensions for Python
- pkgver = 0.29.7.r371.g1a1087bd6
+ pkgver = 3.0.0a11.r191.g8fcc9896f
pkgrel = 1
url = https://cython.org/
arch = i686
arch = x86_64
license = apache
makedepends = git
- depends = python-setuptools
- provides = cython
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ provides = cython=3.0.0a11.r191.g8fcc9896f
conflicts = cython
source = git+https://github.com/cython/cython.git
sha256sums = SKIP
pkgname = cython-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b3fdcda27704..abd906832c02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=cython-git
-pkgver=0.29.7.r371.g1a1087bd6
+pkgver=3.0.0a11.r191.g8fcc9896f
pkgrel=1
pkgdesc="C-Extensions for Python"
arch=('i686' 'x86_64')
url="https://cython.org/"
license=('apache')
-depends=('python-setuptools')
-makedepends=('git')
-provides=('cython')
+depends=('python')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
+provides=("cython=$pkgver")
conflicts=('cython')
source=("git+https://github.com/cython/cython.git")
sha256sums=('SKIP')
@@ -24,15 +24,19 @@ pkgver() {
build() {
cd "cython"
- python "setup.py" build
+ python \
+ -m build \
+ --wheel \
+ --no-isolation
}
package() {
cd "cython"
- python "setup.py" install \
- --optimize 1 \
- --root "$pkgdir"
+ python \
+ -m installer \
+ --destdir="$pkgdir" \
+ dist/*.whl
for f in cygdb cython cythonize; do
mv "$pkgdir/usr/bin"/$f "$pkgdir/usr/bin"/${f}3