summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-02-02 14:09:54 +0800
committerChocobo12019-02-02 14:16:18 +0800
commite4199ce891ead7e9c8f2ec7effa2149dfb2b99d0 (patch)
treedf5af2aa8cc4237590ce4a12508dcd7b1de43635
downloadaur-e4199ce891ead7e9c8f2ec7effa2149dfb2b99d0.tar.gz
newpkg: cython-git 0.29.4.r213.g0ed473f9f-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07427e8b15c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cython-git
+ pkgdesc = C-Extensions for Python
+ pkgver = 0.29.4.r213.g0ed473f9f
+ pkgrel = 1
+ url = https://cython.org/
+ arch = i686
+ arch = x86_64
+ license = apache
+ makedepends = git
+ depends = python-setuptools
+ provides = cython
+ conflicts = cython
+ source = git+https://github.com/cython/cython.git
+ sha256sums = SKIP
+
+pkgname = cython-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04ce8a64d263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=cython-git
+pkgver=0.29.4.r213.g0ed473f9f
+pkgrel=1
+pkgdesc="C-Extensions for Python"
+arch=('i686' 'x86_64')
+url="https://cython.org/"
+license=('apache')
+depends=('python-setuptools')
+makedepends=('git')
+provides=('cython')
+conflicts=('cython')
+source=("git+https://github.com/cython/cython.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "cython"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "cython"
+
+ python setup.py build
+}
+
+package() {
+ cd "cython"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ for f in cygdb cython cythonize; do
+ mv "$pkgdir/usr/bin"/$f "$pkgdir/usr/bin"/${f}3
+ ln -s ${f}3 "$pkgdir/usr/bin"/$f
+ done
+}